Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1836 closed bug (fixed)

OpenGL output not visible on screenshots

Reported by: ekdahl Owned by: korli
Priority: normal Milestone: R1
Component: Kits/OpenGL Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Only a black rectangle is there.

Attachments (3)

screen4.png (94.1 KB) - added by ekdahl 11 years ago.
GLDirectMode-screenshot-intel-extreme-r25221.png (18.3 KB) - added by kaoutsis 11 years ago.
GLTeapot-screenshot-intel-extreme-r25221.png (41.5 KB) - added by kaoutsis 11 years ago.

Download all attachments as: .zip

Change History (22)

Changed 11 years ago by ekdahl

Attachment: screen4.png added

comment:1 Changed 11 years ago by korli

Overlay ?

comment:2 Changed 11 years ago by ekdahl

I'm using vesa driver, so I wouldn't think so.

comment:3 Changed 11 years ago by stippi

What if the OpenGL is trying to grab a direct window lock and does not get it while the screen shot is being taken? Interesting bug, certainly.

comment:4 Changed 11 years ago by korli

Can't reproduce with a Radeon graphics card and GLTeapot. Which app are you using ? Is it real hardware ?

comment:5 Changed 11 years ago by jackburton

Are we reading the front buffer or the backbuffer when taking the screenshot ?

comment:6 in reply to:  4 Changed 11 years ago by ekdahl

Replying to korli:

Can't reproduce with a Radeon graphics card and GLTeapot. Which app are you using ? Is it real hardware ?

It happens with GLDirectMode and GLTeapot for example. It's on real hardware. Also see http://www.haiku-os.org/blog/tangobravo/2008-02-05/haiku_activity_update_4_9_september_2007_5_february_2008#comment-8490 Obviously it also happens for Philippe.

comment:7 Changed 11 years ago by korli

Could you check again ? Stephan did some changes on the buffering. Be sure to give the tested revision. Thanks.

comment:8 Changed 11 years ago by ekdahl

Still the same problem in hrev24145.

comment:9 Changed 11 years ago by korli

VESA mode ?

comment:10 Changed 11 years ago by ekdahl

1280 x 1024 x 16/32 (32 after the default changed)

comment:11 Changed 11 years ago by korli

Could you check against hrev24346 please ?

comment:12 Changed 11 years ago by ekdahl

Yes, I'll test as soon as I get a build system up and running again.

comment:13 Changed 11 years ago by stippi

No need, the output is still mysteriously missing from screenshots. Have no time to look into it right now.

comment:14 Changed 11 years ago by kaoutsis

with hrev25221 and intel_extreme i got these nice screenshots (see attached GLDirectMode-screenshot-intel-extreme-hrev25221.png and GLTeapot-screenshot-intel-extreme-hrev25221.png resolution is 1440x900 and 32 bits/Pixel

Changed 11 years ago by kaoutsis

comment:15 Changed 11 years ago by kaoutsis

further testing: i switch to 16 bits/Pixel from 32 bits/Pixel and run again GLDirectMode and GLTeapot: the screenshots for both apps have only a black window now.

comment:16 Changed 11 years ago by korli

Could you check again please (hrev25952+) ?

comment:17 Changed 11 years ago by ekdahl

Haiku isn't bootable for me ATM, so I can't test it. But it should be easy for anyone to test it using vesa driver.

comment:18 Changed 11 years ago by korli

Resolution: fixed
Status: newclosed

Should be fixed. Please reopen if needed.

comment:19 Changed 11 years ago by ekdahl

Yes, I can confirm that it works here too.

Note: See TracTickets for help on using tickets.