Opened 11 years ago

Closed 10 years ago

#1854 closed bug (invalid)

bcm570x driver (GPL) hangs after short period, panics on 'ifconfig --delete'

Reported by: vortechs2000 Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet Version: R1/pre-alpha1
Keywords: Cc: olivier.coursiere@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

This bug is against the haiku trunk as of Thursday, Feb 21, 2008. I am running on a Dell D600 Latitude laptop with a broadcom 570x chipset.

lspci -nn output looks like this for the broadcom:

02:00.0 Ethernet controller ![0200]: Broadcom Corporation NetXtreme BCM5705M Gigabit Ethernet [14e4:165d] (rev 01)

The driver works for a few minutes after bootup. I am able to get a dhcp lease, download firefox from bebits, etc. But after a short (<10min) period of time, the driver hangs (generally hanging terminal too if I'm trying to run wget).

Also of note is that the usb driver appears to be acting up - the usb mouse works at first, and then fails. If this appears to be related, or the root cause of the network driver hang, feel free to switch the component/summary, etc. There are quite a few messages related to that before the panic.

I have attached the serial console log up to the panic and including a stack crawl. Please let me know if more information is needed. This is quite reproducable, so I can have it back up and into the problem within minutes.

Attachments (1)

session.log.gz (14.9 KB) - added by vortechs2000 11 years ago.
serial console session log including stack crawl

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by vortechs2000

Attachment: session.log.gz added

serial console session log including stack crawl

comment:1 Changed 11 years ago by oco

I was experiencing stability problems with this driver last week too.

Since yesterday, after recompiling latest sources, this driver seems to work. I am still able to surf the web using Seamonkey more than 30 min after booting. Something impossible before...

comment:2 Changed 11 years ago by vortechs2000

Things appear to be stable for me now too, at least with the network and usb drivers.

comment:3 Changed 11 years ago by korli

Could you check with the broadcom570x driver please ? We'd like to drop bcm570x as it's not maintained anymore.

comment:4 Changed 11 years ago by oco

Cc: olivier.coursiere@… added

I was not experiencing this problem. But starting with hrev28637, the broadcom570x finally works on a computer where the GPL one was already working. Previously, the broadcom570x failed to load with this message : PANIC: invalid ife->ifm_data (0xa) in mii_phy_setmedia

comment:5 Changed 10 years ago by axeld

Resolution: invalid
Status: newclosed

The bcm570x driver should be removed, as it has been replaced by the FreeBSD driver.

Note: See TracTickets for help on using tickets.