Opened 11 years ago

Closed 11 years ago

#1877 closed bug (fixed)

Dropdown menu not clickable on all it's surface

Reported by: aldeck Owned by: anevilyak
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Open Screen preflet, the "Workspace count : 4" dropdown menu doesn't open if you click on roughly the right part of it (the text free and arrow area). Seems to be related to the string width of the current item.

Btw, i don't know if it is wanted, but the width of the menu (closed) doesn't resize below a certain item width (ex: one character).

Change History (6)

comment:1 Changed 11 years ago by diver

Is it a dup of #1848 ?

comment:2 Changed 11 years ago by aldeck

Yep, definitely, didn't find it :) I looked for "menu". Can you update the description of #1848 or we can just keep this one as it is more detailed and searchable?

comment:3 Changed 11 years ago by diver

Let's keep this one. :-)

comment:4 Changed 11 years ago by anevilyak

I think I understand what the problem is now, but I'm not yet certain as to the best way to fix it: the popup menu in the menu field is actually hosted in a BMenuBar that's shrunken in size, which in turn contains a menu item that represents the thing you're clicking. However, that item is probably only being sized to its preferred size, which is to say its label width + some margin, while the rest of the bar is seen as dead space, as would be the case for the extra space after the last menu item in a regular menu bar. So in this case the menu item would instead have to be sized so as to fit the whole bar, but I'm not certain as to the best way to go about doing that yet.

comment:5 Changed 11 years ago by anevilyak

Owner: changed from axeld to anevilyak

comment:6 Changed 11 years ago by anevilyak

Resolution: fixed
Status: newclosed

Fixed in hrev27271

Note: See TracTickets for help on using tickets.