Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#1910 closed bug (fixed)

Page fault with hda

Reported by: pieterpan Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Audio/HDA Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

With hrev24364 : When the system has almost finished booting and (I think) wants to do something with the audio driver it kdl's. Probably related to the last commits, hope this info is helpful. Before these changes I would get no kdl, but also no sound (and no controls). If I remove the hda from /boot/beos/system/add-ons/kernel/drivers/bin, it boots fine.

I have a laptop with HD audio. Typed from listdev:

device Multimedia controller ( Audio device ) [4|3|0]
  vendor 8086: Intel Corporation
  device 284b:82801H (ICH8 Family) HD Audio Controller

See attached screenshot (by camera)

If someone knows of a way to copy files from Haiku to ubuntu/windows, without having a network driver, let me know :) Perhaps with fs_shell, but I don't know how to use it? Unfortunately beos does not work on my laptop...

Attachments (1)

DSC02573 (Custom).JPG (108.0 KB ) - added by pieterpan 12 years ago.
kdl with hda driver

Download all attachments as: .zip

Change History (7)

by pieterpan, 12 years ago

Attachment: DSC02573 (Custom).JPG added

kdl with hda driver

comment:1 by korli, 12 years ago

Owner: changed from korli to axeld

comment:2 by axeld, 12 years ago

Component: Drivers/AudioDrivers/Audio/HDA

I'm currently rewriting that part. I hope to get HDA working soon.

comment:3 by korli, 11 years ago

Does it still crash ?

comment:4 by PieterPanman, 11 years ago

Ah, forgot about this ticket. No it does not crash, I suppose this ticket can be closed. However HDA does not work on my laptop yet. It does show up at the Media panel, but without any controls. I can try to play files, but I get no output. I will move this to #1072.

comment:5 by korli, 11 years ago

Resolution: fixed
Status: newclosed

I close this bug then. The driver is not finished btw. Also do you have sound with Linux ?

comment:6 by PieterPanman, 11 years ago

Yes, and I have had sound with the oss for Haiku.

Note: See TracTickets for help on using tickets.