Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#1919 closed bug (fixed)

Cursor hangs on startup

Reported by: meanwhile Owned by: korli
Priority: normal Milestone: R1
Component: Drivers/Audio/auich Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

On startup, Haiku rev. #24385 has a frozen cursor on a blue desktop with nothing on it.

Attachments (9)

serialconnect.txt (151.5 KB) - added by meanwhile 11 years ago.
serial25477.txt (72.9 KB) - added by meanwhile 11 years ago.
3sessionserial25565.txt (64.7 KB) - added by meanwhile 11 years ago.
r25575serial.txt (74.3 KB) - added by meanwhile 11 years ago.
r25593serial.txt (65.6 KB) - added by meanwhile 11 years ago.
r25593serial2.txt (42.9 KB) - added by meanwhile 11 years ago.
r245619boot.txt (77.7 KB) - added by meanwhile 11 years ago.
r26003.txt (67.2 KB) - added by meanwhile 11 years ago.
serial26375.txt (84.9 KB) - added by meanwhile 11 years ago.

Download all attachments as: .zip

Change History (38)

Changed 11 years ago by meanwhile

Attachment: serialconnect.txt added

comment:1 Changed 11 years ago by meanwhile

I got it to run normally just once, which was after choosing 'Default' Video Mode in the Haiku Boot Loader menu. It's maybe because the screen prefs were adjusted after that, that this couldn't be repeated. Running Haiku in VESA mode doesn't help either.

comment:2 Changed 11 years ago by mmlr

Component: - GeneralDrivers/Audio
Owner: changed from axeld to korli

This seems pretty obvious to me:

auich: installing interrupt : 9
More than 99% interrupts of vector 9 are unhandled

So from the syslog it starts immediately after auich apparently installed it's interrupt handler (and probably activated the interrupts). Also checking the syslog the only devices present at interrupt line 9 are audio, a modem and SMBus. So it would make sense if this was actually triggered by auich.

comment:3 Changed 11 years ago by meanwhile

Thanks for kicking the ball onward, mmlr!

comment:4 Changed 11 years ago by korli

Could you try again with hrev25476+ and provide the usual serial output ?

Changed 11 years ago by meanwhile

Attachment: serial25477.txt added

comment:5 Changed 11 years ago by meanwhile

Serial output is in attachment 'serial25477'; the behaviour's unchanged.

comment:6 Changed 11 years ago by korli

Status: newassigned

I need to patch the ac97 code. I hope to do so soon.

comment:7 Changed 11 years ago by korli

Could you try again with hrev25516+ please ?

comment:8 Changed 11 years ago by meanwhile

I will. (but there are haven't been any new builds after hrev25477 from May 12th)

comment:9 Changed 11 years ago by meanwhile

Mixed results now (with hrev25565): the attached serial data show the second boot which was successfull, then the third boot, which wasn't and the fourth, which wasn't either (but got further and showed a Terminal window). I didn't catch data from the first boot as I had the cable connected to the wrong serial port at that time...

Changed 11 years ago by meanwhile

Attachment: 3sessionserial25565.txt added

comment:10 Changed 11 years ago by korli

Could you try again with hrev25574 please ?

Changed 11 years ago by meanwhile

Attachment: r25575serial.txt added

comment:11 Changed 11 years ago by meanwhile

It now shows the Deskbar each time, but the boot process ends there; the OS freezes.

comment:12 Changed 11 years ago by korli

Once again, could you check with hrev25592 ?

Changed 11 years ago by meanwhile

Attachment: r25593serial.txt added

Changed 11 years ago by meanwhile

Attachment: r25593serial2.txt added

comment:13 Changed 11 years ago by meanwhile

(Please ignore the first attachment, r25593serial.txt. Use r25593serial2.txt instead) The last message from the log seemed to repeat forever, so I shut down the PC after a while. Perhaps because of the size of the log caused by this behaviour, copy and paste didn't save the very first part of the log, or I somehow messed up. Let me know when and if you need this part too. Sorry!

comment:14 Changed 11 years ago by korli

Could you check with hrev25616 ?

comment:15 Changed 11 years ago by meanwhile

Hi korli, well it works now: the OS boots nicely (and fully).

BTW, I never had any sound from Haiku yet, but this may be too early, judging by the fact that all sliders in Media prefs. are muted by default and immediately return to that situation after 'unmuting' each and then closing the prefs. window.

comment:16 Changed 11 years ago by meanwhile

Thanks for your patience and hard work!

comment:17 in reply to:  15 Changed 11 years ago by korli

Replying to meanwhile:

Hi korli, well it works now: the OS boots nicely (and fully).

BTW, I never had any sound from Haiku yet, but this may be too early, judging by the fact that all sliders in Media prefs. are muted by default and immediately return to that situation after 'unmuting' each and then closing the prefs. window.

Didn't understand : there is no sound ? Could you post a serial output ?

comment:18 Changed 11 years ago by meanwhile

Earlier Haiku revisions on this PC never had working sound, so in fact this may be a seperate issue/bug. In hrev245619 I do notice a very short crack through my headphones at the moment after the Terminal shows up and before the Deskbar shows up, so there was an audio signal for a short moment. In 'Media' preferences window, when selecting 'Auich ICH' on the tab called 'AC97 Mixer', all the sliders have 'Mute' selected with a blue cross. When removing the blue crosses and then closing the Media preferences window and re-opening it, the blue crosses are there again; that's what I meant by "all sliders are muted". Anyhow, I hope the r245619boot.txt attachment will be informative.

Changed 11 years ago by meanwhile

Attachment: r245619boot.txt added

comment:19 Changed 11 years ago by korli

Could you check again ? Rudolf made a change which could help in your case.

comment:20 in reply to:  19 ; Changed 11 years ago by meanwhile

Replying to korli:

Could you check again ? Rudolf made a change which could help in your case.

It did help...thanks both of you; CD playback is very good and I'll test other audio files. (A 'BeStartup.wav' from BeOS is a bit troublesome for example, but that might end up in another ticket) Thanks again :-) ...and this bug can be closed, I think.

comment:21 in reply to:  20 ; Changed 11 years ago by korli

Replying to meanwhile:

It did help...thanks both of you; CD playback is very good and I'll test other audio files.

Ok, we would need to check accessed registers, some could be invalid uses.

(A 'BeStartup.wav' from BeOS is a bit troublesome for example, but that might end up in another ticket)

Yes. I have problems with such files too.

Thanks again :-) ...and this bug can be closed, I think.

comment:22 in reply to:  21 Changed 11 years ago by korli

Replying to korli:

Replying to meanwhile:

It did help...thanks both of you; CD playback is very good and I'll test other audio files.

Ok, we would need to check accessed registers, some could be invalid uses.

Meanwhile, could you check again with hrev25978 and provide the serial output ? Thanks.

Changed 11 years ago by meanwhile

Attachment: r26003.txt added

comment:23 Changed 11 years ago by meanwhile

Hi korli, the attachment is from the 1st boot of a new install (hrev26003). Cheers, Meanwhile.

comment:24 in reply to:  23 Changed 11 years ago by korli

Replying to meanwhile:

Hi korli, the attachment is from the 1st boot of a new install (hrev26003). Cheers, Meanwhile.

Thanks. It seems ac97_reg_is_valid() should be updated for CODEC_ID_AD1885, avoiding 0x56.

comment:25 in reply to:  23 Changed 11 years ago by korli

Replying to meanwhile:

Hi korli, the attachment is from the 1st boot of a new install (hrev26003). Cheers, Meanwhile.

Could you check again with hrev26168 and provide the serial output ? Thanks.

comment:26 Changed 11 years ago by meanwhile

I'm stuck for the moment on another issue that prevents me from running a new revision on this hardware...(see bugs #2461 and #2470)

comment:27 Changed 11 years ago by meanwhile

Got a recent working Haiku partition again: hrev26375

Changed 11 years ago by meanwhile

Attachment: serial26375.txt added

comment:28 Changed 11 years ago by korli

Resolution: fixed
Status: assignedclosed

Thanks. Bug really fixed.

comment:29 Changed 8 years ago by diver

Component: Drivers/AudioDrivers/Audio/AUICH
Note: See TracTickets for help on using tickets.