Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#193 closed bug (fixed)

disabled BSlider invalidation problems

Reported by: johndrinkwater Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Disabled BSliders fail to redraw, see VirtualMemory for an example.

Attachments (2)

slider.PNG (9.7 KB) - added by jackburton 13 years ago.
Missing slider invalidation
vmem.png (9.0 KB) - added by johndrinkwater 13 years ago.
VirtualMemory with a valid slider

Download all attachments as: .zip

Change History (15)

comment:1 Changed 13 years ago by axeld

Owner: changed from bpmagic@… to axeld

comment:2 Changed 13 years ago by diver

Cc: diver added

comment:3 Changed 13 years ago by stippi

Status: newassigned

comment:4 Changed 13 years ago by diver

I can't reproduce it after hrev17172, maybe already fixed?

comment:5 Changed 13 years ago by jackburton

I can still reproduce it 100%.

comment:6 Changed 13 years ago by johndrinkwater

Cc: stefano.ceccherini@… added

comment:7 Changed 13 years ago by johndrinkwater

I can't reproduce this on hrev17356. The fix points out an error with my bug report - the slider isn't disabled, it just was not invalidating. Stefano: can you still reproduce? (added you as CC)

comment:8 Changed 13 years ago by jackburton

Yes, I can still reproduce if, for example, I move the tab of another window over the slider (see attached screenshot)

comment:9 Changed 13 years ago by johndrinkwater

Ignore attachment 267, turns out a readonly fs disables the slider. Still reproducable. *blush*

(would be lovely to track test environments .. native/hosted:vmware etc)

Changed 13 years ago by jackburton

Attachment: slider.PNG added

Missing slider invalidation

Changed 13 years ago by johndrinkwater

Attachment: vmem.png added

VirtualMemory with a valid slider

comment:10 Changed 13 years ago by axeld

Status: assignedclosed

comment:11 Changed 13 years ago by axeld

Resolution: fixed

comment:12 Changed 13 years ago by axeld

Fixed in hrev17705.

comment:13 Changed 13 years ago by johndrinkwater

Verified with hrev17705 in vmware, closing.

Note: See TracTickets for help on using tickets.