Opened 11 years ago

Closed 11 years ago

#1962 closed bug (invalid)

Some resolutions in VESA no longer work

Reported by: j_freeman Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Some resolutions--such as 1440x900 and 1920x1200--can be selected, but after rebooting the resolution is 800x600. The Screen preflet acts as if whatever was chosen is the current resolution, but of course it isn't.

I don't know the exact revision that stopped working correctly, but it was recent (last 2 weeks or so).

Tested under hrev24560 in VMware Workstation on Windows XP.

Change History (10)

comment:1 Changed 11 years ago by scottmc

I see the same problem on real hardware here. Stuck in 800x600 but prefs app says whatever I pick. Tried with hrev24581 here.

comment:2 Changed 11 years ago by axeld

Should be fixed with hrev24675. Please retest.

comment:3 Changed 11 years ago by j_freeman

Tested in hrev24688. 1440x900 and 1920x1200 are no longer even listed as available resolutions.

comment:4 Changed 11 years ago by stippi

That is because your VESA BIOS does not list them as available modes. The VESA driver can only support the modes listed in your graphics board's BIOS. Ie, it was incorrect before, that the modes got listed, and the code is correct now to not list modes which can not be supported. Please note that your graphics board would probably support these modes if a native driver for your board would be available. Only, the VESA driver can not configure your board for display modes, only through it's VESA BIOS. So everything seems to be working fine now as far as what is possible with VESA.

comment:5 Changed 11 years ago by j_freeman

Ah, I see. In that case, I suppose the ticket can be closed.

Off topic: Is there any way to force a certain mode, one that isn't listed? I ask because it was nice having native fullscreen at 1440x900. ;)

comment:6 Changed 11 years ago by stippi

Wait... you have been using the VESA driver at 1440x900 before, and now this does not work anymore? Because that would be a bug then.

comment:7 in reply to:  6 ; Changed 11 years ago by j_freeman

Wait... you have been using the VESA driver at 1440x900 before, and now this does not work anymore?

Correct. Up until recently, 1440x900 was listed and worked fine.

comment:8 in reply to:  7 Changed 11 years ago by axeld

Replying to j_freeman:

Correct. Up until recently, 1440x900 was listed and worked fine.

Are you sure you haven't changed your hardware that does it? Some adapters publish resolutions like that, some (most) don't. If you are sure your hardware hasn't changed (also no BIOS upgrade in that time), it would be very nice to know what change may have triggered that. Can you try out older revisions?

comment:9 Changed 11 years ago by j_freeman

I'm positive I was able to use the resolution with the VESA driver, but I can't seem to reproduce it. Yesterday I went as far back as a month in testing older revisions, but they either didn't list the resolution or listed it and it displayed as 800x600.

I did upgrade my version of VMware Workstation recently, and that could have very well upgraded the VMware BIOS. That's the only thing I can think of. I'll try and go back to an older version of VMware when I have some time and see what that does.

comment:10 Changed 11 years ago by axeld

Resolution: invalid
Status: newclosed

That would perfectly explain the situation. I'll therefore close this ticket for now.

Note: See TracTickets for help on using tickets.