Opened 11 years ago

Closed 9 years ago

#2013 closed bug (fixed)

[app_server] flickering of the transparent icon while dragging

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Set desktop icon size to 64x64 and try to drag any icon to another place on desktop.

Change History (10)

comment:1 Changed 11 years ago by diver

I think this should be fixed before R1 alpha.

comment:2 Changed 11 years ago by stippi

I did fix the flickering for VESA and I have a plan for how it could be fixed it for accelerated drivers: By using a back buffer that is used only for the region touched by such transparent overlays, separating drawing commands that arrive intersecting with this region into a part that is drawn in software (to the back buffer) and another part which is rendered to the front buffer (accelerated for certain commands). The part that touched the back buffer is then composited with the overlay and copied to the front buffer. This would eliminate flickering in a way similar to the current VESA mode while still using acceleration. If someone wrote a driver for AMD X1400 hardware, that would certainly boost my motivation to work on this... :-)

comment:3 Changed 11 years ago by diver

Strange, but several months ago moving an icon didn't cause flickering.

comment:4 Changed 11 years ago by stippi

Ahm... just to make sure we are talking about the same thing: I am talking about the flickering of the transparent icon that gets attached to the mouse. The flickering is caused by the cursor+icon being removed from the screen and reappearing at the new position when you move the mouse. You mean the same thing, right? What graphics hardware do you use? Does Haiku have a driver for it? Did that situation change a couple months ago?

comment:5 Changed 11 years ago by diver

Ah, I see. There is no flickering in vmware. And I only recently started testing on real hw. So that situation din't changed. False alarm, sorry. Should this be moved to app_server component?

comment:6 Changed 11 years ago by stippi

Component: Applications/TrackerServers/app_server

Oh, yeah, thanks for noticing. Tracker has nothing to do with it.

comment:7 Changed 10 years ago by diver

I think this bug is fixed, I will retest with bigger icon size if stippi won't beat me :-)

comment:8 Changed 10 years ago by diver

Summary: [Tracker] Dragging a file around make icon redraw constantly.[app_server] Dragging a file around make icon redraw constantly.

comment:9 Changed 9 years ago by diver

Summary: [app_server] Dragging a file around make icon redraw constantly.[app_server] flickering of the transparent icon while dragging

I can't reproduce it neither in VirtualBox nor with intel_extreme driver on real hw. Please close.

comment:10 Changed 9 years ago by anevilyak

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.