Opened 11 years ago

Closed 11 years ago

#2051 closed bug (invalid)

Exposure Error with Canon BDCP Plugin, USB Camera (A530)

Reported by: kvdman Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Not sure what the problem here is. The USB stack detects the camera, however plugins installed in /boot/home/config/lib/BDCP_plugins for Exposure 3.03 don't show up in the configuration. I was hoping to get the camera to work with BDCP_canon.so

The screenshot shows an error with elf_resolve_symbol for that plugin, and the other two plugins can't find libusb. It also shows the developer and vendor IDs.

Attachments (2)

exposure-canon.jpg (194.4 KB) - added by kvdman 11 years ago.
ixus.jpg (106.7 KB) - added by kvdman 11 years ago.

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by kvdman

Attachment: exposure-canon.jpg added

comment:1 Changed 11 years ago by stippi

It looks like you are trying to use ZETA software on Haiku, but Haiku only claims BeOS R5 compatibility. Or does Exposure come with it's own libusb.so for it's plug-ins and that is somehow not resolved correctly? In case it is ZETA software, this bug is invalid. Is the source code to Exposure available? If so, it could be made to work by re-compiling it and linking it against Haiku's libdevice.so

comment:2 Changed 11 years ago by mmlr

Exposure has no sources available as far as I know, but Exposure is not the problem. It runs, it's just the plugins that cannot be loaded. You're probably using the ZETA version of those plugins when they require libusb.so. The older BeOS version of the plugins should work though as they use the old USBKit that our usb_raw is compatible with. See http://bebits.com/app/2878 for BeOS versions. I can verify that the PTP plugin as well as ixusdownload work under Haiku as it was the reference software I tested my reimplementation of the USBKit with (http://haiku.mlotz.ch/haiku-usb01.png and http://haiku.mlotz.ch/haiku-ixusdownload.png).

comment:3 Changed 11 years ago by kvdman

The Canon plugin I'm using came off BeShare and doesn't come up with an error that it requires libusb (as seen in the screenshot) it also has a different file size than the two last ones, which were indeed Zeta plugins. But since I don't really know from which platform that plugin is from, I guess this should be marked as invalid.

comment:4 Changed 11 years ago by kvdman

I've also tried IXUSDownload with the camera btw, and USBKit says it can't open /dev/bus/usb/raw... attached shot.

Changed 11 years ago by kvdman

Attachment: ixus.jpg added

comment:5 Changed 11 years ago by kvdman

@mmlr - where did you get the R5 PTP plugin? Both of the ones listed on the BeBits link you provided are for Zeta.

comment:6 Changed 11 years ago by mmlr

Resolution: invalid
Status: newclosed

The message that it could not open "raw" is in fact not an error. It just tells you that the application tried to open the raw node as a USBDevice, which it is not. It is used for io between the USBKit and the raw driver. The devices that it can open are for example "/dev/bus/usb/0". If it was incompatible it would tell you that there is a version mismatch. About the PTP plugin, I got it once before the entry at BeBits was apparently updated with no trace back to the original version. I don't know if you can get a binary anymore (BeShare maybe), but I just discovered that photograbber seems to be on OsDrawer (http://dev.osdrawer.net/plugins/scmsvn/viewcvs.php/?root=photograbber) including the sources for the original PTP add-on. Anyway resolving this as invalid as there is no bug.

Note: See TracTickets for help on using tickets.