Opened 11 years ago

Closed 4 years ago

Last modified 6 months ago

#2066 closed bug (fixed)

Not all resolutions listed for nVidia GeForce 7800 GT

Reported by: j_freeman Owned by: rudolfc
Priority: normal Milestone: R1
Component: Drivers/Graphics/nVidia Version: R1/Development
Keywords: Cc:
Blocked By: #7662 Blocking:
Has a Patch: no Platform: All

Description

The only resolutions listed are:

  • 640x480
  • 800x600
  • 1024x768
  • 1152x864

Obviously the card supports several more. Even my other machine with an old GeForce 4 MX440 lists many more modes.

I'll attach the syslog. Let me know if there's any other helpful info I can provide.

Attachments (1)

syslog (74.3 KB ) - added by j_freeman 11 years ago.

Download all attachments as: .zip

Change History (8)

by j_freeman, 11 years ago

Attachment: syslog added

comment:1 by korli, 10 years ago

Is it still valid ?

comment:2 by axeld, 10 years ago

Owner: changed from axeld to rudolfc
Version: R1/pre-alpha1R1/Development

This might have been fixed in the mean time.

comment:3 by rudolfc, 10 years ago

Hi there J_Freeman,

The driver will only export resolutions suppoorted by your monitor, which is much more limited in capabilities than the card itself.

Since you have a 1280x1024 monitor which is digitally connected (DVI), the driver should offer exactly the modes you stated, plus the native one being 1280x1024.

This was so back then, because the driver detectedt the native resolution then via GPU programming done by the BIOS, and this is still so, now also detected via DDC/EDID. I just confirmed that the driver currently detects your card and should support it (ID is in there).

Please let me know what the current status is for you. Are you able to set 1280x1024?

Bye!

Rudolf.

comment:4 by scottmc, 8 years ago

Blocking: 7662 added

comment:5 by rudolfc, 4 years ago

Hi there,

Just checked that your card is indeed recognized by the driver (ID's are in the syslog). This is true.

That would mean that the following solution should work for you:

hrev49984 added a new nv.settings settings file setting called 'check_edid'. Set this setting to false to block the driver from preventing higher resolution modes from appearing in the ScreenPrefs app. This overcomes the problem of only being able to use low-res modes.

Be carefull not to use too high resolution modes though, as your monitor will not like that...

Closing ticket.

Bye!

Rudolf.

comment:6 by rudolfc, 4 years ago

Resolution: fixed
Status: newclosed

comment:7 by waddlesplash, 6 months ago

Blocked By: 7662 added
Blocking: 7662 removed
Note: See TracTickets for help on using tickets.