Opened 12 years ago

Closed 11 years ago

#2068 closed bug (fixed)

[Pe] Crash on start

Reported by: andreasf Owned by: axeld
Priority: normal Milestone: R1
Component: Applications Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

The Pe Optional Package crashed in hrev24926:

#0 0xffff0102 in ?? () #1 0x00991b16 in debugger () from /boot/beos/system/lib/libroot.so #2 0x005186fb in BView::_CheckOwnerLock () from /boot/beos/system/lib/libbe.so #3 0x0050fe7c in BView::Sync () from /boot/beos/system/lib/libbe.so #4 0x002f1c1b in PText::DrawLine () #5 0x002f1ece in PText::RedrawDirtyLines () #6 0x002f2888 in PText::HiliteSelection () #7 0x002dc6de in PText::WindowActivated () #8 0x00517f0f in BView::_Activate () from /boot/beos/system/lib/libbe.so #9 0x00517f2d in BView::_Activate () from /boot/beos/system/lib/libbe.so #10 0x0051ba7b in BWindow::DispatchMessage ()

from /boot/beos/system/lib/libbe.so

#11 0x005201f8 in BWindow::task_looper () from /boot/beos/system/lib/libbe.so #12 0x004799df in BLooper::_task0_ () from /boot/beos/system/lib/libbe.so #13 0x00995d50 in thread_entry () from /boot/beos/system/lib/libroot.so #14 0x70102fec in ?? ()

Change History (6)

comment:1 by jackburton, 12 years ago

What does the debugger message say ?

in reply to:  1 comment:2 by andreasf, 12 years ago

Replying to jackburton:

What does the debugger message say ?

Sorry, got lost among the Reading symbols / Loading symbols...

Thread 339 called debugger(): View method requires owner and doesn't have one.

To reproduce, repeatedly start Pe. Just now, on the fourth start it crashed. System is SMP.

comment:3 by scottmc, 11 years ago

Does this still happen with PE-2.4.1-RC3 (About box will show compiled on Nov 8 2008)?

comment:4 by scottmc, 11 years ago

Anyone else have this issue with Pe since Nov 8 2008 build? I've been using it and never seen this happen. This one has probably been fixed.

comment:5 by andreasf, 11 years ago

Haven't seen it lately. I suggest to close the ticket.

comment:6 by anevilyak, 11 years ago

Resolution: fixed
Status: newclosed

Thanks for the note!

Note: See TracTickets for help on using tickets.