Opened 11 years ago

Closed 5 years ago

#2072 closed bug (fixed)

[Perl] Socket.pm not found

Reported by: andreasf Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/Command Line Tools Version: R1/Development
Keywords: Cc: bug5lay4r@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

CPAN has problems locating Socket.pm:

Can't locate Socket.pm in @INC (@INC contains: /boot/home/config/lib/perl5/5.10.0/BePC-haiku /boot/home/config/lib/perl5/5.10.0 /boot/home/config/lib/perl5/site_perl/5.10.0/BePC-haiku /boot/home/config/lib/perl5/site_perl/5.10.0 .) at /boot/home/config/lib/perl5/5.10.0/BePC-haiku/IO/Socket.pm line 12.

To reproduce, run cpan followed by install LWP.

Change History (8)

comment:1 by andreasf, 11 years ago

Cc: bonefish added

comment:2 by bonefish, 11 years ago

Cc: bonefish removed

One of perl's tests produces the same error. I haven't looked into that, since our current perl version is built without sockets support (as were the perl builds for BeOS), so I figured that would be the reason. I'll probably come back to that, after I'm through with the tool chain. There shouldn't be any reason for perl socket support not to work under Haiku.

comment:3 by andreasf, 11 years ago

Can you tell where it is being built without socket support? You seemed to have that commented out already in hints/haiku.sh.

in reply to:  3 comment:4 by bonefish, 11 years ago

Replying to andreasf:

Can you tell where it is being built without socket support? You seemed to have that commented out already in hints/haiku.sh.

Sorry, I copied the hints script for BeOS and uncommented/changed the stuff that didn't apply. Still, there was no socket support, so I assumed something has to be done to enable it, and I didn't look into it, since it wasn't really important at that point. My guess would be that one has to add -lnetwork somewhere, so that the Configure tests will find the socket functions, but to be sure just run Configure and check the log.

comment:5 by axeld, 10 years ago

Owner: changed from axeld to nobody
Version: R1/pre-alpha1R1/Development

comment:6 by andreasf, 9 years ago

Perl problems still seem to be with us.

cpan itselfs appears to fall back to downloading with curl.
install LWP still fails with various Can't locate XXX.pm messages during the tests, and so does install Net::SMTP::SSL.

git send-email fails to work:

Unable to initialize SMTP properly.  Is there something wrong with your config? at /boot/common/libexec/git-core/git-send-email line 967

Apparently the Net::SMTP constructor fails.

comment:7 by zzzzz, 6 years ago

Cc: bug5lay4r@… added

comment:8 by pulkomandy, 5 years ago

Resolution: fixed
Status: newclosed

This seems to be fixed with the perl version we have currently.

Note: See TracTickets for help on using tickets.