Opened 11 years ago

Closed 11 years ago

#2074 closed bug (fixed)

Time Preferences window doesn't show up.

Reported by: meanwhile Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

At the first boot after a bi-annual Daylight Saving Time date, Haiku rightfully asks if the time the computer thinks is correct, actually is correct... When replying that it isn't, Haiku asks the user if he wants to change the settings in Time Preferences...OK, that's very considerate. But when confirming this wish, there's no Time Preferences window showing up. Tested in hrev23925.

Change History (6)

comment:1 by stippi, 11 years ago

This bug will go away when we either run mimeset on first boot for all apps, or let the build system take care of installing mimetypes of all apps included with the image. Unless there really is a bug in dstcheck, but at first glance, it seems it should just work.

comment:2 by meanwhile, 11 years ago

I see, thanks...if this is merely the effect of a bug that has already been submitted carrying a more general/abstract character and description, this one can be closed, I guess.

comment:3 by mmlr, 11 years ago

This should work now due to the post install script that does mimesetting. Can this be confirmed/closed?

comment:4 by meanwhile, 11 years ago

I hope somebody else can test this, since -at the moment- I don't have the hardware to run the latest Haiku connected to the internet.

in reply to:  4 comment:5 by meanwhile, 11 years ago

Replying to meanwhile:

I hope somebody else can test this, since -at the moment- I don't have the hardware to run the latest Haiku connected to the internet.

(...as changing the date and rebooting doesn't seem to work)

comment:6 by aldeck, 11 years ago

Resolution: fixed
Status: newclosed

Yep, i can confirm it is fixed! (Tested on hrev27094)

Note: See TracTickets for help on using tickets.