Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2099 closed bug (fixed)

BBox doesn't archive/unarchive its style

Reported by: shinta Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

BBox doesn't archive/unarchive its style. I archived/flattend a BBox, and unarchived it, BBox lost style.

Haiku: near hrev25042 SHINTA

Change History (3)

comment:1 Changed 11 years ago by shinta

It's simply caused by forgetting to initialize fStyle because "_style" property isn't archived if style is B_FANCY_BORDER.

Therefore, BBox works well by modifying as follows:

void BBox::_InitObject(BMessage* archive) { fBounds = Bounds(); fStyle = B_FANCY_BORDER; ...(snip)... }

comment:2 Changed 11 years ago by korli

Resolution: fixed
Status: newclosed

Applied in hrev25082. Thanks!

comment:3 Changed 11 years ago by shinta

Thank you!

Note: See TracTickets for help on using tickets.