Opened 11 years ago

Closed 8 years ago

#2111 closed bug (fixed)

Haiku won't boot when APIC is enabled

Reported by: sklp Owned by: axeld
Priority: normal Milestone: R1
Component: System Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Haiku doesn't seem to be able to boot on my machine unless I turn off APIC in the BIOS. It won't even show the bootsplash; It will just reboot itself almost instantly. It boots up just fine if I turn off APIC.

listdev output attached.

Attachments (1)

listdev (1.9 KB) - added by sklp 11 years ago.
listdev output

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by sklp

Attachment: listdev added

listdev output

comment:1 Changed 11 years ago by sklp

additional note: used hrev25075

comment:2 Changed 11 years ago by jackburton

I've seen this happen too on two HP DC7600 machines.

comment:3 Changed 9 years ago by jackburton

I will check again monday or tuesday on the DC7600 machine.

comment:4 Changed 9 years ago by Coldfirex

jackburton: is this still an issue?

comment:5 Changed 8 years ago by jackburton

Resolution: fixed
Status: newclosed

I was finally able to test again on an HP DC7600. The problem is gone, and Haiku boots correctly also with the APIC enabled.

Note: See TracTickets for help on using tickets.