Opened 11 years ago

Closed 11 years ago

#2139 closed bug (fixed)

Wrong modifier show in menus.

Reported by: bga Owned by: stippi
Priority: normal Milestone: R1
Component: User Interface Version: R1/pre-alpha1
Keywords: Cc: andreasf
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by bga)

It seems that Haiku shows the wrong modifier key in menus. Although the default for operations like Cut/Paste is ALT, it shows CTL throughout the system (in Tracker, StyledEdit, Terminal, etc).

Change History (12)

comment:1 by bga, 11 years ago

Forgot to mention that ALT+C works as expected while CTL+C does not. Even with the menus showing CTL as the modifier key.

comment:2 by bga, 11 years ago

Description: modified (diff)

comment:3 by andreasf, 11 years ago

Cc: andreasf added

Noticed that too, it seems to depend on the keymap: For US International it looked correct but not for German.

Interestingly Ctrl+C does work for the right Ctrl key but not for the left one.

comment:4 by jackburton, 11 years ago

The modifiers situation is a bit confusing: Using the italian keymap, the CTRL shortcut key is the default, and if I choose ALT as shortcut key, then I can't produce some symbols anymore (I.e. the @ symbol, which is produced with ALT-GR + the ò key, in the italian keymap).

comment:5 by aldeck, 11 years ago

You must not trust Menu preflet when it says you are in CTRL mode. It only compares key codes of the left command key and the right command key, and theres a bug in the keymaps (most non english). I'll fix the keymaps shortly.

Concerning the Italian keymap, i could produce the @ symbol, the problem is that ALT-GR becomes RightControl when you're in ALT mode, sure looks odd, but let's keep that for another ticket :-)

comment:6 by aldeck, 11 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev27086

in reply to:  6 comment:7 by korli, 11 years ago

Replying to aldeck:

Fixed in hrev27086

Please revert this: with this change I can't use the standard right option key on French keyboards, ie to type the euro symbol.

comment:8 by aldeck, 11 years ago

Resolution: fixed
Status: closedreopened

Reverted in hrev27087 Advices welcomed :)

comment:9 by stippi, 11 years ago

Can't the Menu preflet be fixed to not touch the right side of the keyboard? And then apply the patch to the keymaps with the same change.

in reply to:  8 comment:10 by andreasf, 11 years ago

It seems like the menu checks the right-hand key to choose the displayed modifier, so messes it up for those keymaps - if that were the case, we could update it to check the left key instead and leave the keymaps as they are?

comment:11 by aldeck, 11 years ago

Good ideas, let's hope it doesn't break something else :)

comment:12 by aldeck, 11 years ago

Resolution: fixed
Status: reopenedclosed

Applied in hrev27095

Note: See TracTickets for help on using tickets.