Opened 11 years ago

Closed 11 years ago

#2171 closed bug (duplicate)

Fast mouse wheel scrolling causes Firefox page to go back or forward

Reported by: cebif Owned by: axeld
Priority: normal Milestone: R1
Component: Applications Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have a problem scrolling with the mouse wheel in Firefox. 1) When I do a sudden burst of mouse wheel movement the page flips back to previous scrolling up. 2) With the opposite scrolling down the page flips forward 3) If I scroll slowly up or down the page will not flip forward or back. 4) Of course the page cannot flip forward or back if it is the first page of the session that I have opened or flip forward if I am on the last page that I opened. The expected behaviour is that the page will only scroll up or down faster with a fast mouse wheel movement. This behaviour does not happen in other versions of Beos or other operating systems as far as I know. I was testing with Firefox 2.0.0.12 and hrev24959 on its own partition.

Change History (8)

comment:1 Changed 11 years ago by bonefish

This might be the same problem as #1625. Do you use a PS/2 mouse?

comment:2 Changed 11 years ago by umccullough

Also confirmed here with Fx 2.0.0.15pre BONE (Never seen the same behavior on BeOS).

I do have a PS2 mouse, but haven't tested #1625. The behavior mentioned in #1625 does seem familiar though.

comment:3 Changed 11 years ago by umccullough

It does look like standard firefox behavior (in windows and linux) is to move forward/backward in the browser history if you hold the shift key while also scrolling with the mouse wheel.

Not sure if this functionality is related to the issue or not, but I figured I'd note it.

It does appear to be reversed in that case, where shift-scrolldown moves you back a page and shift-scrollup moves you forward. With the above bug scrolling too quickly upward moves you back a page, while scrolling too quickly downward moves you forward (as mentioned in the original description).

Would it be more correct to mark this as an input_server issue?

comment:4 in reply to:  3 ; Changed 11 years ago by bonefish

Replying to umccullough:

Would it be more correct to mark this as an input_server issue?

It would be nice, if you could check with a USB mouse (if possible). If it doesn't occur then, I really think it is a problem at driver (respectively bus manager) level and should be assigned to Marcus.

comment:5 in reply to:  4 Changed 11 years ago by umccullough

Replying to bonefish:

It would be nice, if you could check with a USB mouse (if possible).

Wow, I apologize for being too dense to try that out on my own :)

So, I tested the exact same machine with a USB mouse instead and it appears to work just fine. It also eliminated the behavior seen in #1625 (I'll add a separate note there)

comment:6 in reply to:  1 Changed 11 years ago by cebif

Replying to bonefish:

This might be the same problem as #1625. Do you use a PS/2 mouse?

Yes it is a ps/2 wireless mouse, Logitech MouseMan wheel mouse.

comment:7 Changed 11 years ago by stippi

I am guessing that wheel data from the Y direction "spills over" into the X direction. This could explain both what Tracker does and what Firefox does. Maybe the PS/2 driver is assuming the wrong number of bits (too few) for Y data and reads X data which is in fact still Y data.

comment:8 Changed 11 years ago by axeld

Resolution: duplicate
Status: newclosed

Duplicate of #1625.

Note: See TracTickets for help on using tickets.