Opened 11 years ago

Closed 10 years ago

#2205 closed bug (fixed)

[S3 driver] screen goes black after reboot

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Graphics/S3 Version: R1/pre-alpha1
Keywords: Cc: gerald, zajac
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

On behalf of totish (http://qube.ru/users/totish) I have Compaq Presario 714EA laptop with S3 Twister-K (card ID: 8d02, vendor ID:S3 Inc.(0x5333) ) Gerald Zajac sent me S3 driver compiled for R5, which i use in BeOS and Dano. I have 5 partitions with following OSes installed:

Windows 98 Mandriva Dano BeOS Max Haiku

The problem is: after reboot my laptop's screen goes black until i press space (which will activate first menu item in bootman) or hard reset. After that Windows 98 will start to load with half-shifted windows logo. This problem happens with Dano, BeOS Max and Haiku, but not with Windows 98 and Mandriva. If i remove S3 driver reboot works ok in all BeOS variants (i see text printed by BIOS). And windows logo is normal again.

Please tell what additional info i should provide to help with this bug?

Change History (7)

comment:1 Changed 11 years ago by diver

Cc: gerald zajac added

comment:2 Changed 11 years ago by diver

Summary: [S3 diver] gives black screen after reboot[S3 diver] screen goes black after reboot

comment:3 Changed 11 years ago by diver

We need subcomponent for s3 driver with Gerald as owner.

comment:4 Changed 11 years ago by modeenf

Component: Drivers/GraphicsDrivers/Graphics/S3

comment:5 Changed 10 years ago by anevilyak

Summary: [S3 diver] screen goes black after reboot[S3 driver] screen goes black after reboot

comment:6 Changed 10 years ago by diver

totish reported that this bug is fixed.

comment:7 Changed 10 years ago by axeld

Resolution: fixed
Status: newclosed

Thanks for the update.

Note: See TracTickets for help on using tickets.