Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2220 closed bug (fixed)

Undesired B_INPUT_METHOD_STOPPED is sent to input method (IM)

Reported by: shinta Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

When bottomline window is closed, B_INPUT_METHOD_STOPPED is sent to input method whether unconfirmed strings exist or not.

I think that B_INPUT_METHOD_STOPPED should be sent only if unconfirmed strings exist.

This bug influence to Anthy for Haiku. When I convert in bottomline window and don't confirm kana-kanji strings, next one character is disposed because B_INPUT_METHOD_STOPPED make Anthy flush next one character.

Haiku: hrev25124+ SHINTA (bug No.16)

Attachments (1)

TextView.diff (814 bytes ) - added by shinta 11 years ago.
This patch fixes this problem.

Download all attachments as: .zip

Change History (3)

by shinta, 11 years ago

Attachment: TextView.diff added

This patch fixes this problem.

comment:1 by korli, 11 years ago

Resolution: fixed
Status: newclosed

Applied in hrev25518. Thanks!

comment:2 by shinta, 11 years ago

Thanks!

Note: See TracTickets for help on using tickets.