Opened 11 years ago

Closed 11 years ago

#2238 closed bug (fixed)

KDL on mounting BFS drive

Reported by: myob Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I've got Haiku running on real hardware here, when I go to mount my Zeta drive, Haiku KDLs. Unfortunately, it gives me no option to use the keyboard and mouse after that so I can't get a backtrace

KDL text is:

"PANIC: could not read block 28682635: bytesRead: -1, error: Device seek error"

The Haiku and Zeta partitions are on the same SATA HDD.

Change History (6)

comment:1 by stippi, 11 years ago

Unless you are using a USB keyboard, you should be able to enter "sc" into the kernel debugger to get a stack trace. If nothing else, take photos of the KDL output and attach them to this bug. Thanks!

comment:2 by myob, 11 years ago

I'm using a USB keyboard... that is the complete output unfortunately! I'll try to find a PS/2 board later on.

Should add - its hrev25477, the partition used to mount - last tried about November 2007 - and comes up clean in a chkbfs from Zeta.

comment:3 by emitrax, 11 years ago

Is it possible to add sc as an automatic command when entering KDL? It seems like a good solution in this situation.

comment:4 by axeld, 11 years ago

There is a better one: it's possible to handover the USB keyboard to the BIOS again during the KDL session. That way, USB keyboards can be used there, too. IIRC Michael wanted to implement this some time ago...

But there is another solution: just remove the USB drivers from Haiku, and enable USB legacy emulation in your system's BIOS. Then you should be able to use it as well. To remove the Haiku USB drivers, you should remove the USB bus manager at least (eventually also UHCI/EHCI).

comment:5 by emitrax, 11 years ago

what's the status of this bug? myob have you tried again with the latest revision? Does it still happen?

comment:6 by axeld, 11 years ago

Component: File Systems/BFSDrivers/Disk
Resolution: fixed
Status: newclosed

Since there were no updates, I'm closing this one. From the panic, I assume it was the LBA48 bug in the IDE bus manager that caused this.

Note: See TracTickets for help on using tickets.