Opened 11 years ago

Closed 10 years ago

#2258 closed bug (fixed)

resize-button in tab changes color sometimes

Reported by: jdawin Owned by: stippi
Priority: normal Milestone: R1
Component: User Interface Version: R1/pre-alpha1
Keywords: Cc: j_freeman
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Under certain conditions, the resize- and close-buttons in the tab change their color on clicking. To reproduze this behaviour do this:

  1. open a folder, say "Haiku" from the Desktop
  2. open another folder inside the first one, say "beos"
  3. open yet another inside this second folder, say "etc"
  4. now activate the "Haiku"-window, and maximize it, if it isn't already
  5. make it smaller by dragging the bottom-right edge
  6. scroll one the scrollbars
  7. move the window around
  8. click on the resize-button. Now, or after a few more clicks on the resize-button

the button should change its color to dark blue or grey, which is unexpected. To see the close-button change its color, click on it without releasing the mouse-button

The effect is quite unpredictable. I could not figure out a rule for which color comes up or which window needs how many clicks on resize to show the effect. But the above method worked quite reliably for me.

Attachments (1)

screen_button.png (45.4 KB ) - added by jdawin 11 years ago.
the resize-button turned blue

Download all attachments as: .zip

Change History (3)

by jdawin, 11 years ago

Attachment: screen_button.png added

the resize-button turned blue

comment:1 by j_freeman, 11 years ago

Cc: j_freeman added

I've seen this from time to time as well.

comment:2 by stippi, 10 years ago

Resolution: fixed
Status: newclosed

The button rendering is done using bitmaps since some time, so this bug, although it wasn't truly fixed, should not be reproducible anymore.

Note: See TracTickets for help on using tickets.