Opened 12 years ago

Closed 11 years ago

#2276 closed bug (fixed)

If HAIKU_ROOT_USER_REAL_NAME contains UTF8 chars, Haiku fails at Bootscript

Reported by: stippi Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

For example, if I put "Stephan Aßmus" there, the boot icons light up until the rocket and then all activity stops. Either this is a build system problem or a problem in the multi-user code paths. Assigning to Ingo in any case... :-)

Change History (5)

comment:1 by jackburton, 12 years ago

What about a problem in bash instead ?

comment:2 by bonefish, 12 years ago

Works fine here (OpenSuse 10.3). On which platform did you build? How does the generated/objects/common/passwd look like?

comment:3 by bonefish, 11 years ago

Any update? My HAIKU_ROOT_USER_REAL_NAME has been "Stephan Aßmus" for weeks now.

comment:4 by stippi, 11 years ago

Sorry for the delay...

My build platform used to be Ubuntu 7.10, now it is 8.04. I just tested the result from 8.04 and it works fine, I can boot now. I guess this bug can be closed then.

generated/objects/common/passwd looks like this:

sshd:x:1001:100:sshd user:/var/empty:/bin/true
stippi:x:0:0:Stephan Aßmus:/boot/home:/bin/bash

In either less/Gnome Terminal and gedit. Don't know how to tell the encoding. I leave it up to you to mark this as "fixed". In any case it seems like a host platform specific problem.

comment:5 by bonefish, 11 years ago

Resolution: fixed
Status: newclosed

OK, if this can't be reproduced anymore, we can as well close it.

Note: See TracTickets for help on using tickets.