Opened 11 years ago

Closed 11 years ago

#2291 closed bug (fixed)

vm_soft_fault when discovering bluetooth devices

Reported by: monni Owned by: oruizdorantes
Priority: normal Milestone: R1
Component: Network & Internet/Bluetooth Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

How to reproduce: Run bt_discovery before starting bluetooth_server Experienced behavior: No KDL Expected behavior: whine like a baby

KERN: BT device_control: ioctl() opcode 12999 size 7. KERN: BT command_complete: 11 09:10:00: KERN: BT assembly_rx: count 12 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT device_control: ioctl() opcode 12999 size 7. KERN: BT command_complete: 11 14:0c:00: KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: Last message repeated 14 times. KERN: BT assembly_rx: count 14 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT device_control: ioctl() opcode 12999 size 12. KERN: BT command_complete: 16 01:04:05: KERN: BT assembly_rx: count 6 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 3 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: vm_soft_fault: va 0x0 not covered by area in address space KERN: vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x0, ip 0x800a28a8, write 1, user 0, thread 0x13d KERN: BT device_control: ioctl() opcode 12999 size 17. KERN: BT command_complete: 21 19:04:0a: KERN: BT assembly_rx: count 6 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland KERN: BT assembly_rx: count 16 0x00000000 0x8058f3e0 KERN: Last message repeated 15 times. KERN: BT assembly_rx: count 1 0x00000000 0x8058f3e0 KERN: BT assembly_rx: Frame goes up! KERN: BT post_packet_up: HCI not present, Posting to userland

Change History (6)

comment:1 by oruizdorantes, 11 years ago

Status: newassigned

Hi monni,

Are you sure this happens before running the bluetooth server? Its because only the server comunicates with the driver, so the syslog would not have sense.

You ran more than once the bluetooth server? Currently it is really in pre-alpha and does not make, clean many stuff. Closing the debug window is not closing the server for example.

thanks for the testing!

comment:2 by monni, 11 years ago

I think I tried starting bluetooth_server once but it closed itself after minute or two... then I tried bt_discovery but it didn't print anything... so I looked in syslog and found that piece of information. Afterwards I started bluetooth_server again and bt_discovery worked without soft_fault.

It was right after I booted the system so memory was pretty much clean of residues from previous tests...

comment:3 by monni, 11 years ago

crash happens inside bt_discovery

got stack trace that contains only

<_APP_>:DumpInfoFPQ29Bluetooth11LocalDevice + 0x01a2

comment:4 by oruizdorantes, 11 years ago

Status: assignedclosed

Fixed at revision 26612. Calling receive_data() with null pointer for receiver. thanks!

comment:5 by oruizdorantes, 11 years ago

Status: closedreopened

Fixed at revision 26612. Calling receive_data() with null pointer for receiver. thanks!

comment:6 by oruizdorantes, 11 years ago

Resolution: fixed
Status: reopenedclosed

false reopen due browser refresh

Note: See TracTickets for help on using tickets.