Opened 12 years ago

Closed 10 years ago

#2356 closed bug (fixed)

usb stack deadlocks after plugging in card reader

Reported by: monni Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

How to reproduce:

  1. Open terminal with tail -f /var/log/syslog
  2. Plug usb card reader without any cards

Experienced behavior: Terminal deadlocks Expected behavior: Terminal continues to respond to mouse events

Concerning threads: 35 usb explore, holds "legacy driver", waits for "devfs lock" 158 sh, holds "devfs lock", waits for "legacy driver" 198 Terminal, waits for "devfs lock", blocks "usb explore"

First significant entries for thread 35 are: <usb>:RescanDrivers5StackP11rescan_item + 0x001b <usb>:ExploreThread5StackPv + 0x0101

Last significant entry for thread 35 is: <kernel>:publish_deviceFP5devfsPCcP10BaseDevice + 0x007a

First significant entry for thread 158 is: <kernel>:vfs_free_io_context + 0x0078

Last significant entry for thread 158 is: <kernel>:UninitDevice12LegacyDevice + 0x0028

First significant entry for thread 198 is: <kernel>:_user_open + 0x00a1

Last significant entry for thread 198 is: <kernel>:devfs_open_FP9fs_volumeP8fs_vnodeiPPv + 0x0072

I omitted functions between those because I don't think they're relevant to finding the cause and I would have to hand-copy them because I don't have serial cable here.

Change History (4)

comment:1 by mmlr, 12 years ago

Component: Drivers/USBSystem/Kernel
Owner: changed from mmlr to axeld

This is a deadlock between the devfs and the legacy driver system. USB is only the trigger, not the problem itself. This was introduced with the new device manager, assigning to Axel.

comment:2 by axeld, 10 years ago

Version: R1/pre-alpha1R1/Development

Does this still happen?

comment:3 by monni, 10 years ago

Hasn't happened for me lately...

comment:4 by axeld, 10 years ago

Resolution: fixed
Status: newclosed

Thanks for the quick update! There have been quite some changes in that area, so I assume it to be fixed. Please reopen if it happens again.

Note: See TracTickets for help on using tickets.