Opened 11 years ago

Closed 11 years ago

#2358 closed bug (fixed)

Couldn't unmount usb disk after copying a file

Reported by: emitrax Owned by: axeld
Priority: high Milestone: R1
Component: Drivers/Disk Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Easy to reproduce.

  • Mount a usbdisk
  • Copy a file to the usbdisk (I used a text one but it shouldn't matter)
  • Open the original file
  • Try unmounting the usbdisk

Behavior: It doesn't unmount. Picture attached.

Attachments (2)

unmounting2.jpg (112.5 KB) - added by emitrax 11 years ago.
unmounting.jpg (70.7 KB) - added by emitrax 11 years ago.
After cancel the first time and retrying to unmount

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by emitrax

Attachment: unmounting2.jpg added

Changed 11 years ago by emitrax

Attachment: unmounting.jpg added

After cancel the first time and retrying to unmount

comment:1 Changed 11 years ago by kvark

Can't reproduce with hrev25951. My actions: 1) mounted usb (throught the desktop right-click, to /NO_NAME) 2) touch ~/my.txt in Terminal 3) copy my.txt to the /NO_NAME using Tracker 4) opened ~/my.txt in Tracker, wrote some symbols 5) right click on the usb drive on the desktop, click Unmount command

The result: Tracker /NO_NAME window is automaticly closed, the device is unmounted properly.

comment:2 Changed 11 years ago by emitrax

Resolution: fixed
Status: newclosed

Problem seems fixed. Closing it.

I should learn to always add the revision number.

Note: See TracTickets for help on using tickets.