Opened 11 years ago

Closed 11 years ago

#2376 closed bug (fixed)

Build fails with new style SCSI device paths on Ubuntu

Reported by: monni Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

On my Ubuntu 7.04 device paths for storage devices are formatted as /dev/disk/by-id/xxxx, /dev/disk/by-label/yyyy or /dev/disk/by-uuid/zzzz

Build system fails with "Bad file descriptor" when trying to write boot code

Using old style /dev/hd* or /dev/sd* doesn't work reliably because drive letters change between boots depending on number of hot-plugged drives.

I guess expected behavior would be to ask underlying operating system for correct block device associated with the disk id. I don't see it very hard to implement as new paths are symbolic links that can be resolved.

Change History (1)

comment:1 by bonefish, 11 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev26006.

Note: See TracTickets for help on using tickets.