Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2378 closed bug (fixed)

Print in PDF - Look & Feel issues

Reported by: un_spacyar Owned by: julun
Priority: normal Milestone: R1
Component: Printing Version: R1/pre-alpha1
Keywords: Cc: julun, laplace, un_spacyar@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

When you print a document using the "Print PDF" option and enters into the configuration screen, there are some formatting issues. Please, see the attachments for more details about that.

These issues were found in Haiku raw image # 25619

Attachments (7)

Step_01.png (40.7 KB ) - added by un_spacyar 11 years ago.
Step 1
Step_01.2.png (40.7 KB ) - added by un_spacyar 11 years ago.
Step 1
Step_02.png (59.2 KB ) - added by un_spacyar 11 years ago.
Step 2
Step_03.png (60.1 KB ) - added by un_spacyar 11 years ago.
Step 3
AdvancedSettings.png (32.3 KB ) - added by un_spacyar 11 years ago.
Advanced Settings screen.
SavePDF.png (31.5 KB ) - added by un_spacyar 11 years ago.
Save PDF screen
Font_Settings.png (18.7 KB ) - added by un_spacyar 11 years ago.
Font settings

Download all attachments as: .zip

Change History (18)

by un_spacyar, 11 years ago

Attachment: Step_01.png added

Step 1

by un_spacyar, 11 years ago

Attachment: Step_01.2.png added

Step 1

by un_spacyar, 11 years ago

Attachment: Step_02.png added

Step 2

by un_spacyar, 11 years ago

Attachment: Step_03.png added

Step 3

comment:1 by diver, 11 years ago

Great, this was one of my todo bug reports, thanks!

comment:2 by laplace, 11 years ago

Cc: julun added

The dialogs are not font (size) sensitive.

Karsten, would you like to fix that?

comment:3 by julun, 11 years ago

Cc: laplace added
Owner: changed from laplace to julun

Hi Micheal,

I can do it, reassigned.

comment:4 by julun, 11 years ago

Resolution: fixed
Status: newclosed

fixed in hrev26398

comment:5 by un_spacyar, 11 years ago

Cc: un_spacyar@… added
Resolution: fixed
Status: closedreopened

There are some issues not fixed. Please, see the following files:

AdvancedSettings.png SavePDF.png

PD: sorry for the delay retesting this issue.

Thanks!

by un_spacyar, 11 years ago

Attachment: AdvancedSettings.png added

Advanced Settings screen.

by un_spacyar, 11 years ago

Attachment: SavePDF.png added

Save PDF screen

comment:6 by julun, 11 years ago

Hmmm, the last one looks really strange and i can't reproduce it here. What font settings are in use? Did you rebuild the complete image?

comment:7 by diver, 11 years ago

Also if one set font size to 18 pt there will be even more layout issues. So I think this bug should be reopened indeed.

comment:8 by un_spacyar, 11 years ago

Response to julun:

I'm using the default font settings (12 pt). I attach a new screenshot of my Font settings. I didn't rebuild the image. I retested using this image: vmhaiku.hrev26477.zip

by un_spacyar, 11 years ago

Attachment: Font_Settings.png added

Font settings

comment:9 by julun, 11 years ago

@un_spacyar: I tested against vmhaiku.hrev26770 and it works there. There where some changes done on BSlider and the layout code depends on that. The popup bug still exists. Can you verify please?

@diver: I probably won't change that much on those handcrafted layout stuff, I would wait until we finally can drop R5 support and go with layouts.

comment:10 by julun, 11 years ago

Resolution: fixed
Status: reopenedclosed

fixed in hrev26924, but will only work for normal font size...

comment:11 by un_spacyar, 11 years ago

I retested with r.26829 and works correctly with font = 12pt.

In any way, the problems with bigger fonts exists in practically all the system, so I think is not related to this Ticket.

Note: See TracTickets for help on using tickets.