Opened 11 years ago

Closed 11 years ago

#2393 closed bug (fixed)

[Terminal]: vim hangs (-> high cpu usage) when closing terminal while vim is opened

Reported by: emitrax Owned by: bonefish
Priority: normal Milestone: R1
Component: Applications/Terminal Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Honestly it seems more a vim problem.

  • run vim
  • close the terminal

I expect vim to exit as well, but instead it hangs on port AppLooperPort.

See screenshots. hrev25990.

Attachments (2)

vim.jpg (48.6 KB ) - added by emitrax 11 years ago.
vim_bt.jpg (82.9 KB ) - added by emitrax 11 years ago.

Download all attachments as: .zip

Change History (5)

by emitrax, 11 years ago

Attachment: vim.jpg added

by emitrax, 11 years ago

Attachment: vim_bt.jpg added

comment:1 by emitrax, 11 years ago

I said it seems more a vim problem, because if I run StyleEdit for instance, it quits when I close the terminal as I expect.

comment:2 by bonefish, 11 years ago

I couldn't reproduce the problem in the first place, but it might have been caused by the broken signal handling in vim (in the BeOS port). Please check whether it is fixed in hrev26034.

comment:3 by emitrax, 11 years ago

Resolution: fixed
Status: newclosed

Problem fixed. Thanks.

Note: See TracTickets for help on using tickets.