Opened 11 years ago

Closed 10 years ago

#2395 closed bug (fixed)

Preferences; Backgrounds; Icon label outline

Reported by: nutela Owned by: korli
Priority: normal Milestone: R1
Component: Preferences/Backgrounds Version: R1/pre-alpha1
Keywords: Cc: mattmadia@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

  1. When no image selected (Image: None) the option "Icon label outline" is unchecked but is still applied which is wrong.
  1. The "Icon label outline" checkbox cannot be checked when no image for the desktop background is selected.

Attachments (2)

BG1.png (13.7 KB) - added by nutela 11 years ago.
note the gray Icon label outline checkbox
BG2.png (27.3 KB) - added by nutela 11 years ago.
note the Icon label outline checkbox

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by nutela

Attachment: BG1.png added

note the gray Icon label outline checkbox

Changed 11 years ago by nutela

Attachment: BG2.png added

note the Icon label outline checkbox

comment:1 Changed 11 years ago by nutela

Revision 25950

comment:2 Changed 10 years ago by mmadia

Just to note, if a user enables the Icon label outline. They will need to select a background to disable it.

comment:3 Changed 10 years ago by mmadia

Cc: mattmadia@… added

comment:4 Changed 10 years ago by mmadia

Steps to reproduce bug:

Open Backgrounds preflet.

Make sure Icon label outline is not checked. Set Image to any image and apply. Set Image to None and Apply.

The GUI control for Icon label outline will be disabled. In addition, Tracker will believe Icon label outline is enabled.

comment:5 Changed 10 years ago by korli

hrev29189 should help.

For the second point, is this really a bug ? IMO the preflet disabled the checkbox for a good reason, because its value cannot be changed when no image is selected.

comment:6 Changed 10 years ago by stpere

Resolution: fixed
Status: newclosed

Hi, I commited a fix for this in hrev30495! Thanks! If any problems arise, ping me :-)

Note: See TracTickets for help on using tickets.