Opened 11 years ago

Closed 11 years ago

#2429 closed bug (duplicate)

[Terminal] Resizing Terminal is very slow

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Resizing Terminal is very slow, in the same time CPU is idle. It seems to be a new ( < month) issue. Also while resizing text flickers too much.

Change History (10)

comment:1 Changed 11 years ago by bonefish

Can't reproduce this under VMware. Resizing is zippy and it doesn't flicker. Did you test on real hardware?

comment:2 Changed 11 years ago by diver

Yes I did.

comment:3 Changed 11 years ago by anevilyak

I haven't seen this on real hardware here either (Radeon X800). Nor any of the other slowness issues reported.

comment:4 Changed 11 years ago by bonefish

Do you have a PS/2 or USB mouse?

comment:5 Changed 11 years ago by diver

I have a Logitech USB wheel mouse.

comment:6 Changed 11 years ago by anevilyak

Logitech wireless USB mouse here also, though until recently it was hooked up via PS2 due to lack of OHCI. That seems to have made no performance difference here though.

comment:7 in reply to:  6 Changed 11 years ago by bonefish

Component: - GeneralServers/app_server

Replying to anevilyak:

Logitech wireless USB mouse here also, though until recently it was hooked up via PS2 due to lack of OHCI. That seems to have made no performance difference here though.

OK, I guess that rules out that it is somehow USB mouse related. Moving to app server component.

comment:8 Changed 11 years ago by stippi

My _guess_ is that these "slowness" tickets are actually all duplicates of #1823. To harden this suspicion, please test an installation without the native graphics driver (so that the VESA driver is used). If the symptoms disappear, it's #1823. My best guess is that 1823 is an MTRR setup issue, but I don't know enough about this stuff.

comment:9 Changed 11 years ago by diver

I tried VESA mode and it indeed removed slowness and flickering.

comment:10 Changed 11 years ago by bonefish

Resolution: duplicate
Status: newclosed

Thank! Closing as dup of #1823

Note: See TracTickets for help on using tickets.