Opened 11 years ago

Closed 9 years ago

#2449 closed bug (fixed)

Log feed does not respect newlines in commit message

Reported by: andreasf Owned by: haiku-web
Priority: normal Milestone: R1
Component: Website/Trac Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking: #2423
Has a Patch: no Platform: All

Description

The Trac 0.10 Timeline feed used to include full multi-line commit messages. In Trac 0.11 this was apparently shortened to one line with ellipsis, leaving the the Log feed as official source of full commits.

The Log feed however differs from the old Timeline feed in mangling newlines into a single hardly readable block of text, e.g.:

* line one * line two

Originally reported for Opera by diver: http://dev.haiku-os.org/ticket/2423#comment:3

I can confirm that this happens for Safari 3.1.1 and Mac OS X Mail 3.3 as well.

This might be due to Trac writing raw newlines into the XML stream, which a conforming XML reader collapses to one white space character.

Change History (1)

comment:1 Changed 9 years ago by nielx

Resolution: fixed
Status: newclosed

Fixed (a while ago actually, see #7316...

Note: See TracTickets for help on using tickets.