Opened 11 years ago

Closed 11 years ago

#2452 closed bug (duplicate)

[Subversion] svn co in haiku drops to gdb or KDL

Reported by: scottmc Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #1641 Blocking:
Has a Patch: no Platform: x86

Description

When using svn to get haiku it works fine, but when I try to use svn co to check out from a site it drops to gdb and/or KDL. I managed to capture a gdb screencap, and on a reboot and retry I got a KDL instead. I'm using the subversion linked from the dev tools page (v1.1.3 i think), and running on hrev25993 currently.

Attachments (2)

screen5.png (298.1 KB ) - added by scottmc 11 years ago.
svn-kdl-sc1.jpg (376.3 KB ) - added by scottmc 11 years ago.
picture of the KDL sc output

Download all attachments as: .zip

Change History (15)

by scottmc, 11 years ago

Attachment: screen5.png added

comment:1 by scottmc, 11 years ago

Retry 3 and it seems to be working for me now. It may have been that I mistyped the line, but in any case a mistyped line shouldn't drop to KDL.

comment:2 by mmlr, 11 years ago

When you get that gdb again, it would be nice if you could also get a back trace using the "bt" command so that one can see from where it got into this trouble. If you get a KDL, please do the same and capture the output with a digital camera for example and attach it here if possible.

comment:3 by anevilyak, 11 years ago

Out of curiosity, since you mentioned being able to check out the Haiku tree ok (which I can confirm works here also) ... what protocol is the other site you're trying using? svn://, http, https, or what?

comment:4 by scottmc, 11 years ago

It uses http It also seems that the SVN_EDITOR environment variable wasn't set by default when I installed subversion. How do you set it manually?

comment:5 by anevilyak, 11 years ago

export SVN_EDITOR=vim or whatever editor you want. Should be able to add that to .profile so it's set automatically.

comment:6 by anevilyak, 11 years ago

Was the Haiku checkout using http also?

comment:7 by mmlr, 11 years ago

Oh, you just installed that BeOS package? That could cause a few problems indeed, as it contains an updated pipefs replacing the one present. This was intended on BeOS because the pipefs there has issues. But on Haiku it's not really a good idea to replace it, as this most certainly isn't compatible with the current filesystem API. You should try a package that only supplies the subversion binaries. For example you could try http://haiku.mlotz.ch/subversion-1.1.3-bone.zip or the more current http://haiku.mlotz.ch/subversion-1.4.6-bone.zip. Note that these support svn, http and https, but not svn+ssh, as the apr_proc_stub and some code utilising it is missing from them.

comment:8 by scottmc, 11 years ago

I just followed the instructions from: http://www.haiku-os.org/documents/dev/getting_the_source_code so it was svn:// to check out haiku.

comment:9 by bonefish, 11 years ago

Component: Build System- General
Owner: changed from bonefish to axeld

by scottmc, 11 years ago

Attachment: svn-kdl-sc1.jpg added

picture of the KDL sc output

comment:10 by scottmc, 11 years ago

This just might be another dup of #1641.

comment:11 by umccullough, 11 years ago

The stacktrace in the attached screenshot definitely would suggest that ;)

rtl8139 driver is extremely unstable from what I gather talking to various people in #haiku who have tested with it.

I can probably test this tonight on an ipro1000-based machine to see what happens.

comment:12 by scottmc, 11 years ago

As with all the other 8139 crashes I have with this board, if it try the same thing enough times I can eventually get it to work. I was able to check my change in after several tries. I'll try installing that same subversion onto my vmware image and see if it's more stable there, and if so then we can close this as a dupe, hold open for a day or still till I verify this is the case.

comment:13 by axeld, 11 years ago

Blocked By: 1641 added
Resolution: duplicate
Status: newclosed

Installing npipefs should do no harm, as a) BeOS file systems aren't modules, so they aren't picked up at all, and b) there is no pipefs anymore, as pipes are now implemented differently.

Anyway, this is indeed a dup of #1641.

Note: See TracTickets for help on using tickets.