Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2469 closed bug (fixed)

Haiku (r26165) does not detect SATA DVD/CDROM drive.

Reported by: Bouncer Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Ever since I installed it (several months ago) - Haiku has not been able to recognize my SATA DVD drive.

I am currently testing with Haiku hrev26265.

Previously Haiku had no problems with a PATA DVD drive from the same manufacturer.

I am testing on real hardware. Intel Quad Core CPU. The DVD unit in question is a LITEON Model LH-20A1S12C.

Linux has no problems recognizing (or even installing from) from this SATA DVD. So I know it is in good working order.

Haiku simply cannot see this drive. It does not show up in the mount list. It does not appear on the list if I cycle a CD a few times. Other SATA Hard Drives do register properly.

I will attempt to include my syslog

Attachments (4)

my.syslog (393.3 KB ) - added by Bouncer 11 years ago.
syslog.r26212 (97.6 KB ) - added by Bouncer 11 years ago.
my.syslog.2 (275.2 KB ) - added by Bouncer 11 years ago.
haiku-cdda-syslog.txt (13.9 KB ) - added by marcusoverhagen 11 years ago.
different CD-ROM

Download all attachments as: .zip

Change History (17)

by Bouncer, 11 years ago

Attachment: my.syslog added

comment:1 by anevilyak, 11 years ago

Component: - GeneralDrivers/Disk
Owner: changed from axeld to marcusoverhagen

I might be wrong but I thought the SATA driver is currently missing ATAPI support, meaning this won't work yet no matter what you do. Switching to correct component in any case.

comment:2 by marcusoverhagen, 11 years ago

Status: newassigned

The AHCI sata driver already supports ATAPI. (works for me :-)

On this machine, the drive is detected, but some ATAPI command seems to fail.

ata command 0xa0 is the PACKET command, more debug output needs to be added to see which ATAPI command is beeing executed.

3386	KERN: [34mahci:[0m AHCIPort::PostReset port 3
3387	KERN: [34mahci:[0m device signature 0xeb140101 (ATAPI)
3388	KERN: [34mahci:[0m AHCIPort::ScsiInquiry port 3
3389	KERN: [34mahci:[0m model number:  LITE-ON DVDRW LH-20A1S                 
3390	KERN: [34mahci:[0m serial number:                     
3391	KERN: [34mahci:[0m firmware rev.: 9L08   
3392	KERN: [34mahci:[0m sg_memcpy phyAddr 0x0325b388, addr 0x83a5b388, size 96
3393	KERN: [34mahci:[0m ahci_get_restrictions, cookie 0x90bc5480
3394	KERN: [34mahci:[0m AHCIPort::ScsiGetRestrictions port 3: isATAPI 1, noAutoSense 1, maxBlocks 256
3395	KERN: publish device: node 0x90c1fc60, path disk/scsi/0/3/0/raw, module generic/block_io/device_v1

3656	KERN: [34mahci:[0m AHCIPort::InterruptErrorHandler port 3, fCommandsActive 0x00000001, is 0x40000001, ci 0x00000001
3657	KERN: [34mahci:[0m ssts 0x00000113
3658	KERN: [34mahci:[0m sctl 0x00000300
3659	KERN: [34mahci:[0m serr 0x00000000
3660	KERN: [34mahci:[0m sact 0x00000000
3661	KERN: [34mahci:[0m Task File Error
3662	KERN: ahci: sata_request::finish ATA_ERR set for command 0xa0
3663	KERN: ahci: sata_request::finish status 0x51, error 0x20

comment:3 by marcusoverhagen, 11 years ago

Please create a new syslog with hrev26205 or newer. I added error output for ATAPI commands.

comment:4 by Bouncer, 11 years ago

OK - Here is the latest syslog, for hrev26212

by Bouncer, 11 years ago

Attachment: syslog.r26212 added

comment:5 by marcusoverhagen, 11 years ago

Are you sure that a CD is inserted? Can you please insert / cycle a CD and try again?

by Bouncer, 11 years ago

Attachment: my.syslog.2 added

comment:6 by Bouncer, 11 years ago

OK.

1) First - I boot a fresh Haiku installation (hrev26212) with an Audio CD

in the DVD drive.

2) Since it does not see the disk - I cycle disk out and back in to the drive.

Again - it does not see it.

3) I remove the Audio CD and load a data CD (an anonymous MS driver install disk).

It does not auto-mount. But I do see an entry in the Mount list and I am able to mount it.

4) Next - I unmount and remove the data CD and re-insert the Audio CD.

Again - it is not recognized.

Have I been mistaken? Does Haiku not support regular audio CD's ?

comment:7 by axeld, 11 years ago

Definitely works over here with a SATA DVD ROM drive. What audio CD is it? Have you tried different ones?

comment:8 by marcusoverhagen, 11 years ago

The only failing commands are: "ATAPI packet 00", Test unit ready, fails when no CD is inserted. "ATAPI packet 28", Read, might fail for non-data CDs.

Auto-mounting doesn't seem to work for me, too. Execept during boot.

I don't know why audio CDs don't work. Perhaps B_SCSI_READ_CD uses the wrong command for this CD-ROM.

by marcusoverhagen, 11 years ago

Attachment: haiku-cdda-syslog.txt added

different CD-ROM

comment:9 by marcusoverhagen, 11 years ago

reproducible here, audio CDs can't be read with CDDA

comment:10 by marcusoverhagen, 11 years ago

Should be fixed in hrev26332, please test.

comment:11 by Bouncer, 11 years ago

I am pleased to report that audio CD's in my SATA DVD ROM are now being detected. I was able to mount and unmount the CD's without any incidents. All Files are viewable.

I think this ticket can be closed now.

comment:12 by marcusoverhagen, 11 years ago

Resolution: fixed
Status: assignedclosed

comment:13 by axeld, 11 years ago

I just checked on another system of mine, and there the SATA DVD-ROM doesn't seem to work. I'll investigate this before reopening the ticket, though.

Note: See TracTickets for help on using tickets.