Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2475 closed bug (invalid)

SoundBlaster 16 PCI is not detected

Reported by: BenoitRen Owned by: korli
Priority: normal Milestone: R1
Component: Drivers/Audio Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #1278 Blocking:
Has a Patch: no Platform: x86

Description

I run Haiku nightlies on real hardware. My Creative SoundBlaster 16 PCI card does not get detected by Haiku. And I don't just mean that it doesn't have drivers for it. It doesn't show up in syslog or listdev. Everything else is being detected properly.

I'm attaching the syslog.

Attachments (4)

syslog (138.4 KB ) - added by BenoitRen 11 years ago.
umccullough_lspci.txt (1.0 KB ) - added by umccullough 11 years ago.
lspci -nn from linux
umccullough_syslog_r26212.txt (74.8 KB ) - added by umccullough 11 years ago.
syslog from Haiku hrev26212
umccullough_listdev_r26212.txt (1.5 KB ) - added by umccullough 11 years ago.
listdev from Haiku hrev26212

Download all attachments as: .zip

Change History (22)

by BenoitRen, 11 years ago

Attachment: syslog added

comment:1 by umccullough, 11 years ago

If I'm not mistaken, these cards were based on the Ensoniq chips (es1370/71/73) and even offered some sort of backward-compatible ISA-emulation features or something...

I think I've got a variant of this card at home somewhere - I'll dig it up and give it a try myself.

comment:2 by umccullough, 11 years ago

It appears that I do have an SB 16 PCI card - labeled CT4740 (is that the same as yours?)

I'll give it a try shortly in my core 2 duo box.

by umccullough, 11 years ago

Attachment: umccullough_lspci.txt added

lspci -nn from linux

by umccullough, 11 years ago

syslog from Haiku hrev26212

by umccullough, 11 years ago

listdev from Haiku hrev26212

comment:3 by umccullough, 11 years ago

Well, it may or may not be the same revision card (Mine is detected as a Creative SB PCI128/Ensoniq AudioPCI 5880)

But I attached linux lspci output, Haiku syslog, and Haiku listdev output in case that helps track down your issue.

I'll look again, I may even have another card of this series somewhere around here.

comment:4 by umccullough, 11 years ago

One more thought, have you tried pulling the card out and re-seating it? I've had problems where cards aren't detected due to dust or foreign matter in the PCI slot.

Does Linux detect it?

comment:5 by anevilyak, 11 years ago

Could this perhaps be another victim of ticket #3 ?

comment:6 by BenoitRen, 11 years ago

I booted Puppy Linux on this PC, and went through the ALSA wizard. It didn't detect my sound card. Then I requested the list of PCI devices, and it didn't list it there.

My sound card works fine in Windows, though.

It's possible that ticket #3 is at work here, as before passing control to the OS, the BIOS displays a list of all detected hardware, and one entry is "Multimedia Controller", with an assigned IRQ of "NA".

Looking through the .inf file that's part of Creative's drivers, the id of my card can be either of the following: CTL0001, CTL0031, CTL0041, CTL0043.

comment:7 by umccullough, 11 years ago

Is it possible you have the BIOS set to not set an IRQ for that specific slot?

What happens if you move the card to another slot entirely?

Older machines had a way to reset ESCD information from the BIOS - you could try that... but I'm not sure if that was ISA specific or not (I'm guessing it was since it doesn't seem to be a feature on newer machines).

comment:8 by BenoitRen, 11 years ago

I've looked through my BIOS settings, and there is no setting that has to do with my sound card.

I'd rather not move it to another slot.

comment:9 by korli, 11 years ago

Component: System/KernelDrivers/Audio
Owner: changed from axeld to korli

comment:10 by korli, 11 years ago

Out of curiosity, what let you think this SB16 card is a PCI one ?

comment:11 by umccullough, 11 years ago

Those referenced model numbers all appear to be ISA cards... the fact that it doesn't show up in haiku's listdev output definitely suggests non-PCI :)

I found this INF file reference:

http://server.elektro.dtu.dk/ftp/database/Drivers/Drivers-org/Sound/SB16%20PCI%20PNP%20Support%20CD/SB16AWE.INF

comment:12 by korli, 11 years ago

Resolution: invalid
Status: newclosed

It's consistent with Linux not showing the device in lspci.

comment:13 by BenoitRen, 11 years ago

I'm saying it's a PCI card because it was sold as such, Windows detects it as "Plug & Play", and Creative's software labels it as such. ISA cards weren't Plug & Play as far as I know.

If it really is an ISA card, I'd think that Linux' ALSA would support it. I'll boot into Linux tomorrow and try to get more information.

I do not appreciate closing the ticket when it's not confirmed that my card being ISA is the cause. In fact, an Ensoniq card DOES show in the attached lspci from Linux!

BeOS 5 did support my sound card. D:<

in reply to:  13 comment:14 by anevilyak, 11 years ago

Replying to BenoitRen:

I'm saying it's a PCI card because it was sold as such, Windows detects it as "Plug & Play", and Creative's software labels it as such. ISA cards weren't Plug & Play as far as I know.

You would be incorrect, ISA PnP did in fact exist, and sound blasters were amongst the first card to implement that standard.

in reply to:  13 comment:15 by umccullough, 11 years ago

Replying to BenoitRen:

I'm saying it's a PCI card because it was sold as such, Windows detects it as "Plug & Play", and Creative's software labels it as such. ISA cards weren't Plug & Play as far as I know.

As Rene points out, ISA most certainly did support ISAPNP (was horrible, btw) - perhaps it was mis-advertised.

If it really is an ISA card, I'd think that Linux' ALSA would support it. I'll boot into Linux tomorrow and try to get more information.

I do not appreciate closing the ticket when it's not confirmed that my card being ISA is the cause. In fact, an Ensoniq card DOES show in the attached lspci from Linux!

If it doesn't show up in lspci from linux, it's not likely a PCI device.

BeOS 5 did support my sound card. D:<

BeOS and Windows both supported ISA... so that doesn't change anything here.

You can verify if it's ISA or not by looking at the slot it's in, PCI slots are significantly different from ISA slots. An ISA slot is usually colored black, while most PCI slots are white

http://en.wikipedia.org/wiki/Industry_Standard_Architecture

vs

http://en.wikipedia.org/wiki/Peripheral_Component_Interconnect

in this picture, you'll see an example of an AGP slot (brown, far left), 6 PCI slots (white), and one ISA slot (black, far right)

http://en.wikipedia.org/wiki/File:Abit-kt7-large.jpg

comment:16 by rossi, 11 years ago

From everything mentioned here I would also guess it's an ISA card. BeOS had two Soundblaster drivers, the original one done by Be, which among others supported the AWE64 cards and a specific SB16 driver developed by a friend of mine (bitpull)and later on someone refreshed this driver, but I forgot the name of this person.

comment:17 by BenoitRen, 11 years ago

I booted into Puppy Linux and ran the lshw tool. It identified my sound card as an ISA one, of the type "Creative ViBRA16C PnP". So I guess I'm out of luck until someone implements ISA support.

At the time, my card was advertised in the shop booklet (I just looked) as "Soundblaster 16 PnP bulk". No indication of the type of slot it fits in.

comment:18 by luroh, 9 years ago

Blocked By: 1278 added
Note: See TracTickets for help on using tickets.