Opened 11 years ago

Closed 7 years ago

#2482 closed bug (fixed)

Panic while automounting usb stick

Reported by: emitrax Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

It seems it happens only on first boot, but I'm not sure whether it is a coincidence, those a race condition, or not.

See screenshots attached.

Attachments (2)

AutoMounter.4.jpg (161.9 KB) - added by emitrax 11 years ago.
add_poses.jpg (151.2 KB) - added by emitrax 11 years ago.

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by emitrax

Attachment: AutoMounter.4.jpg added

Changed 11 years ago by emitrax

Attachment: add_poses.jpg added

comment:1 Changed 11 years ago by mmlr

Owner: changed from axeld to mmlr
Status: newassigned

This is not a race condition or anything, it's a plain simple timeout that happens. The device does not respond quickly enough therefore usb_disk will abort and return a timeout error ("error: Operation timed out"). The timeout I (arbitrarily) set is 2 seconds right now, which might just not be enough. Please increase the timeout in src/add-ons/kernel/drivers/disk/usb/usb_disk/usb_disk.cpp line 145 by a second until you don't see this happening anymore and report how much it needs. Other subsystems seem to use timeouts of up to 20 seconds, but I don't really want to increase it that much. Maybe 3 or 5 seconds would be acceptable though.

comment:2 Changed 11 years ago by mmlr

Any news on this? It's possible that the device locked up because of error recovery not working and that causing the timeout. Could you please check if a current revision >= hrev28934 still exhibits this problem?

comment:3 Changed 10 years ago by emitrax

I just gave it a quick test and I did the following:

1 - plug the stick 2 - mount it 3 - open it 4 - close it 5 - right click on the icon -> unmount

icon does not disappear, plus using the right click menu of the desktop and going to the mount entry makes the menu hang in the there. hrev28958.

comment:4 Changed 9 years ago by mmlr

So the original issue isn't reproducible anymore? The other issue mentioned in comment 3 would deserve a new bug report if it is still happening. Otherwise I'd like to close this one.

comment:5 Changed 7 years ago by diver

Component: - GeneralDrivers/Disk
Resolution: fixed
Status: in-progressclosed

Probably fixed.

Note: See TracTickets for help on using tickets.