Opened 11 years ago

Closed 10 years ago

#2486 closed bug (invalid)

[MediaPlayer] crash in mp3_decoder

Reported by: diver Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Audio & Video/Codecs Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Crash occurred on some random search.

Thread 3508 caused an exception: Segment violation
Reading symbols from /boot/beos/system/lib/libbe.so...(no debugging symbols found)...done.
Loaded symbols for /boot/beos/system/lib/libbe.so
Reading symbols from /boot/beos/system/lib/libmedia.so...(no debugging symbols found)...done.
Loaded symbols for /boot/beos/system/lib/libmedia.so
Reading symbols from /boot/beos/system/lib/libtracker.so...
(no debugging symbols found)...done.
Loaded symbols for /boot/beos/system/lib/libtracker.so
Reading symbols from /boot/beos/system/lib/libtranslation.so...(no debugging symbols found)...done.
Loaded symbols for /boot/beos/system/lib/libtranslation.so
Reading symbols from /boot/beos/system/lib/libtextencoding.so...
(no debugging symbols found)...done.
Loaded symbols for /boot/beos/system/lib/libtextencoding.so
Reading symbols from /boot/beos/system/lib/libstdc++.r4.so...(no debugging symbols found)...done.
Loaded symbols for /boot/beos/system/lib/libstdc++.r4.so
Reading symbols from /boot/beos/system/lib/libroot.so...done.
Loaded symbols for /boot/beos/system/lib/libroot.so
Reading symbols from /boot/beos/system/lib/libpng.so...done.
Loaded symbols for /boot/beos/system/lib/libpng.so
Reading symbols from /boot/beos/system/lib/libz.so...done.
Loaded symbols for /boot/beos/system/lib/libz.so
Reading symbols from /boot/beos/system/add-ons/media/plugins/avi_reader...done.
Loaded symbols for /boot/beos/system/add-ons/media/plugins/avi_reader
Reading symbols from /boot/beos/system/add-ons/media/plugins/avcodec...done.
Loaded symbols for /boot/beos/system/add-ons/media/plugins/avcodec
Reading symbols from /boot/beos/system/add-ons/media/plugins/mp3_decoder...done.
Loaded symbols for /boot/beos/system/add-ons/media/plugins/mp3_decoder
[tcsetpgrp failed in terminal_inferior: Invalid Argument]

[Switching to team /boot/beos/apps/MediaPlayer (3493) thread MediaPlayer Audio Ou control (3508)]
0x00c2273b in III_antialias ()
   from /boot/beos/system/add-ons/media/plugins/mp3_decoder
(gdb) bt
#0  0x00c2273b in III_antialias ()
   from /boot/beos/system/add-ons/media/plugins/mp3_decoder
#1  0x00c237e9 in do_layer3 ()
   from /boot/beos/system/add-ons/media/plugins/mp3_decoder
#2  0x97ed40d2 in ?? ()
#3  0x43865524 in ?? ()
#4  0x185ccae9 in ?? ()
#5  0x93631fda in ?? ()
#6  0x78286aa3 in ?? ()
#7  0x293ef184 in ?? ()
#8  0x185d4195 in ?? ()
#9  0xf8215280 in ?? ()
#10 0x78288629 in ?? ()
#11 0xe2856fdb in ?? ()
#12 0x0000040f in ?? ()
#13 0x7828878c in ?? ()
#14 0x00c1d88d in mp3Decoder::DecodeNextChunk ()
   from /boot/beos/system/add-ons/media/plugins/mp3_decoder
Previous frame inner to this frame (corrupt stack?)
(gdb) 

Change History (3)

comment:1 Changed 10 years ago by leavengood

Hey Diver, a lot has changed in the MediaPlayer and Media Kit since this was logged. Does it still occur (assuming you can reproduce it)?

comment:2 Changed 10 years ago by diver

Feel free to close this ticket as I don't even remember which file I played and how I made it crash.

comment:3 Changed 10 years ago by marcusoverhagen

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.