Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#25 closed bug (fixed)

qemu 0.6.1/0.7.0 + 2005.05.26 haiku.image

Reported by: lizdeika@… Owned by: bpmagic@…
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

vesa dies ant app_server too: qemu line: qemu -hda /path/to/haiku.image -boot c -serial stdio > haiku.log

log: http://mif.vu.lt/~dejo0032/bla/haiku.log

Change History (9)

comment:1 Changed 14 years ago by axeld

Owner: changed from axeld to bpmagic@…

comment:2 Changed 14 years ago by axeld

As you can easily see at this line: vm_page_fault: killing team 0x16, ip 0x26894b ("app_server_seg0ro" +0x6894b)

The app_server is crashing. AFAICT that happens when you don't boot in a 32 bit mode. IOW the app_server seems to be the cause. Everything works fine when you select a 32 bit video mode (but that one might not be available in qemu).

comment:3 Changed 14 years ago by lizdeika@…

Ok seems like qemu does support up to 24 bit color depth. But m$ vpc2004 supports 32 bit. Quote from help: "Virtual PC 2004 supports 1, 2, 4, 8, 16, and 32-bit color depths. " And results are the same: http://mif.vu.lt/~dejo0032/bla/haiku.txt

comment:4 Changed 14 years ago by bpmagic@…

Component: KernelServers

comment:5 Changed 14 years ago by bpmagic@…

This is a known bug, or, rather, an unimplemented feature. 32-bit video modes are the only ones supported ATM, but IIRC the only changes needed are to the Painter backend to support other modes.

comment:6 Changed 14 years ago by bpmagic@…

Status: newassigned

comment:7 Changed 14 years ago by lizdeika@…

Oh silly me :) It works in vpc2004 and in vmware5 when i choose 32bit color depth in boot menu. vmware: http://uosis.mif.vu.lt/~dejo0032/bla/vmhaiku.png

p.s. should mouse work ? i can see it trying to detect usb mouse but those virtuals emulate ps2.

comment:8 Changed 14 years ago by jackburton

Resolution: fixed

comment:9 Changed 14 years ago by jackburton

Status: assignedclosed
Note: See TracTickets for help on using tickets.