Opened 11 years ago

Closed 11 years ago

#2548 closed bug (fixed)

Drive Setup reports wrong volume name after an initilization

Reported by: scottmc Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/DriveSetup Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have a drive with 2 haiku partitions on it. I named them Haiku-CF1 and Haiku-CF2. I then unmounted CF2 and used Drive Setup to initialize CF2. After it was done it falsely reported that CF1 was successfully initialized. Screenshots attached.

Attachments (2)

init-before.png (47.6 KB) - added by scottmc 11 years ago.
init-after.png (42.0 KB) - added by scottmc 11 years ago.

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by scottmc

Attachment: init-before.png added

Changed 11 years ago by scottmc

Attachment: init-after.png added

comment:1 Changed 11 years ago by anevilyak

Component: - GeneralApplications/DriveSetup
Owner: changed from axeld to stippi

Switching components

comment:2 Changed 11 years ago by stippi

Status: newassigned

hrev26643 should fix this, can you confirm?

comment:3 Changed 11 years ago by scottmc

Give me some more time to try this again, been having trouble getting it to where I can boot off of one drive and try to install to the other dual partitioned drive reliably in recent builds. I'll try it again next week I hope.

comment:4 Changed 11 years ago by anevilyak

hrev26828 did warn that things would probably be unstable for a bit as the I/O scheduler / DMA work is more thoroughly integrated, so you might want to keep a watch on the commits list for further work on that before trying again, as that's likely the cause of your current issues.

comment:5 Changed 11 years ago by scottmc

Using hrev26876 I was able to check this and it is in fact working as it's supposed to be, so this one can be closed.

comment:6 Changed 11 years ago by korli

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.