Opened 13 years ago

Closed 11 years ago

#256 closed bug (fixed)

[app_server] strange color conversion

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by jackburton)

Sometimes when you start Scroll Bar you could get really strange color conversion. This happens to me 3-4 times, but i didn't find the way how to reproduce it. It mostly happens if you run haiku pretty long. Screenshot will follow. Tested with rev16575 infer vmware.

Attachments (2)

scrollbar.PNG (7.6 KB) - added by diver 13 years ago.
screenshot of this bug
weird.PNG (8.2 KB) - added by jackburton 13 years ago.
Expander window with some problems

Download all attachments as: .zip

Change History (14)

Changed 13 years ago by diver

Attachment: scrollbar.PNG added

screenshot of this bug

comment:1 Changed 13 years ago by axeld

Owner: changed from bpmagic@… to darkwyrm

comment:2 Changed 13 years ago by korli

The same happens on Cortex btw

comment:3 Changed 13 years ago by johndrinkwater

I've had this with other apps too (ScreenSavers being one this morning); should probably reassign to app_server ?

and Terminal - http://flickr.com/photos/johndrinkwater/112831560/

(at least, as far as I see, these are related)

comment:4 Changed 13 years ago by diver

Owner: changed from darkwyrm to axeld

comment:5 Changed 13 years ago by axeld

Summary: [Scroll Bar] strange color conversionstrange color conversion

comment:6 Changed 13 years ago by axeld

This could be caused by communication problems with the app_server.

comment:7 Changed 13 years ago by jackburton

Description: modified (diff)
Platform: All

I experienced a simipar problem with Expander too (just once). I think it could be related.

Changed 13 years ago by jackburton

Attachment: weird.PNG added

Expander window with some problems

comment:8 Changed 13 years ago by axeld

I think there might be a bug in the communication layer with the app_server - sometimes the results seem to be clobbered; maybe there is an off-by-one error that's only produced *very* rarely.

comment:9 Changed 12 years ago by diver

Component: - GeneralServers/app_server
Version: R1 development

Didn't saw this bug during a year now. I think it could be closed.

comment:10 Changed 12 years ago by stippi

No this bug still happens sometimes. It can also be reproduced with the test environment. I think it is a timing issue. Usually, some stuff (system fonts, colors?) are initialized already, but very rarely not.

comment:11 Changed 11 years ago by diver

Summary: strange color conversion[app_server] strange color conversion

comment:12 Changed 11 years ago by stippi

Resolution: fixed
Status: newclosed

Hopefully fixed by hrev26192. Please reopen if you see it again. The same bug affected Tracker (upper 10% black background and very small icon text size), LaunchBox (black top icon(s)), Playground (similar to screenshot "weird.PNG") and probably other apps.

Note: See TracTickets for help on using tickets.