Opened 11 years ago

Closed 6 years ago

#2600 closed bug (no change required)

PowerStatus crash

Reported by: donn Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/PowerStatus Version: R1/pre-alpha1
Keywords: Cc: planche2k@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

With APM enabled (in config/settings/kernel/drivers/kernel), PowerStatus crashes system right away.

Power down via "Shutdown ..." menu item does work.

Haiku hrev26947, MSI K8N Neo4 motherboard with NForce4 chipset. (Not a laptop.)

panic + 0x0029 vm_page_fault + 0x010d page_fault_exception + 0x00a5 int_bottom +0x0036 (nearest) kernel iframe at 0x96fafd18 (end = 0x96fafd68)

eax 0x530a ebx 0x1ff ecx 0x80ff edx 0x96faffff esc 0x80000007 edi 0x216 ebp 0x96fafda4 esp 0x96fafd4c eip 0x800b7726 eflags 0x10216 vector: 0xe, error code 0x2

12 96fafd18 (+140) 800b7726 <kernel>:call_apm_bios_FP9bios_regs + 0x0026 13 96fafda4 (+64) 8006b79f8 <kernel>:get_battery_info_FD12battery_info + 0x0040 14 96fafde4 (+48) 800b728f <kernel>:apm_control_FPCcUlPrU1 + 0x001f

Attachments (1)

listdev (3.5 KB ) - added by donn 11 years ago.
feast your eyes

Download all attachments as: .zip

Change History (11)

comment:1 by donn, 11 years ago

Component: - GeneralSystem/Kernel
Platform: Allx86

comment:2 by andreasf, 11 years ago

Cc: andreas.faerber@… added

I'm unable to reproduce this with QEMU+gcc4 at hrev26956, nor with SiS chipset board (desktop) and gcc2 at hrev26941.

comment:3 by scottmc, 11 years ago

@donn, Can you run listdev in a terminal and post your output here?

by donn, 11 years ago

Attachment: listdev added

feast your eyes

comment:4 by Disreali, 10 years ago

Cc: mdisreali@… added

comment:5 by andreasf, 10 years ago

Cc: andreas.faerber@… removed

comment:6 by andreasf, 10 years ago

Cc: planche2k@… added

I still don't see a crash. Installing doesn't seem to work though: I neither get an icon nor an error message. System is gcc4, SiS, desktop.

comment:7 by Disreali, 10 years ago

Has anyone tested this on a r1a1 build? I only use virtual images as my hardware won't boot Haiku.

comment:8 by Disreali, 8 years ago

Cc: mdisreali@… removed

comment:9 by modeenf, 7 years ago

Component: System/KernelApplications/PowerStatus

or testad in r1a4? perhaps we can close this?

comment:10 by modeenf, 6 years ago

Resolution: no change required
Status: newclosed

As no one can recreate it and 5 years old, i'm closing it, if problem exist we can reopen it.

Note: See TracTickets for help on using tickets.