Opened 11 years ago

Closed 11 years ago

#2628 closed bug (fixed)

TIFF translator doesn't handle TIFF files created by MacOS screenshot utility

Reported by: rossi Owned by: axeld
Priority: normal Milestone: R1
Component: Add-Ons/Translators Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

TIFF translator doesn't handle files created by MacOS screenshot utility. Sample file attached. Happens or hrev27010.

Change History (8)

comment:1 Changed 11 years ago by rossi

Sample file available upon request rossi <at> webpositive.org, couldn't attach the sample to this ticket, due to file size limitations.

comment:2 Changed 11 years ago by axeld

Component: - GeneralAdd-Ons/Translators

Not even zipped?

comment:3 Changed 11 years ago by scottmc

Haiku (as of hrev26990) is using tiff 3.6.1, current released version of libtiff is 3.8.2: http://ports.haiku-files.org/wiki/media-libs/tiff/3.8.2/1 This may or may not fix this issue.

comment:4 Changed 11 years ago by rossi

UPDATE: The issue ist still present in hrev28335, as I can't attach test files due to size limitations, here are two links to test files:

http://www.streetpainter.net/haiku/tickets/2628/Photoshop001.tiff http://www.streetpainter.net/haiku/tickets/2628/Photoshop002.tiff

Hope these files help to nail down the issue ;-)

Cheers, Rossi

comment:5 Changed 11 years ago by korli

Resolution: fixed
Status: newclosed

Fixed in hrev28370

comment:6 Changed 11 years ago by korli

Resolution: fixed
Status: closedreopened

comment:7 Changed 11 years ago by korli

Status: reopenednew

Axel should know better how to fix the RAW translator :)

comment:8 Changed 11 years ago by axeld

Resolution: fixed
Status: newclosed

Fixed in hrev28381. Sorry that I can't put my test images into the repository - I don't remember where I got them from, so there might be copyright issues. I only have a Pentax K-100D for testing (from which I could provide sample images).

Note: See TracTickets for help on using tickets.