Opened 11 years ago

Closed 11 years ago

#2669 closed bug (fixed)

scsi scheduler takes 100% cpu load

Reported by: rossi Owned by: bonefish
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The scsi scheduler threads suddenly sucks all cpu cycles (100% cpu usage) and in 30% of all cases causes a complete system freeze sooner or later, however never recovers from the 100% load.

This happens on hrev27208 during installation from an usb stick (from which the system has been booted).

It does take different amounts of time with each install trial, before the effect takes place.

In 1 out of roughly 15 tries I actually managed a complete install before the system went bananas.

This behaviour was not present with the previous builds (from before Sunday).

Rossi

Change History (11)

comment:1 by anevilyak, 11 years ago

Component: - GeneralSystem/Kernel

This looks like a duplicate of ticket #2604.

comment:2 by emitrax, 11 years ago

It's actually a different bug and I was just going to open a bug about this. It seems it has been introduced lately.

The CPU in this case goes to 100% and the scsi scheduler is the only thread eating up the CPU.

comment:3 by rossi, 11 years ago

Actually I'm pretty sure that this issue didn't exist with my previous build (was done on sunday based on sundays repository head revision) don't remember the revision number.

Besides the installation, the svn update caused this to happen as well and to my bad luck trashed the source tree beyond cleanup's capabilities ;-(

comment:4 by bga, 11 years ago

I actually got that too when checking out the sources under VMWare. System became completely unusable and eventually completely locked up.

comment:5 by bonefish, 11 years ago

Owner: changed from axeld to bonefish

I'm in the process of implementing an actual I/O scheduling algorithm. That might also fix this issue. If not, I'll look into afterwards.

comment:6 by bga, 11 years ago

Hi Ingo.

Just to clarify, this was introduced with one of the recent changes to the IO scheduiler stuff. Not long ago I could download the tree under Haiku without problems, no I can not anymore as this will happen.

This also shows how our scheduler bahaves *REALLY* badly. I hace 4 cores on this machine and I can see in process controller one being used at 100%. But the system grinds to a halt and I can´t do anything (like moving windows, opening menus).

comment:7 by anevilyak, 11 years ago

I doubt that's the thread scheduler's fault...I've had 100% CPU usage in plenty of things and the sys was still responsive on one CPU. More likely some locks are being held while that thread loops that result in everything else blocking eventually.

comment:8 by bonefish, 11 years ago

In hrev27216 the new I/O scheduling algorithm is in place. I tried "svn co" and "svn up" in VMware and things worked without problems (not very fast, though -- 31 min for the checkout with 256 MB RAM). I haven't tried an installation. Please report how that goes, now.

comment:9 by bga, 11 years ago

Thanks. worked perfectly here. AFAIK, this bug can be closed.

comment:10 by rossi, 11 years ago

I can only second that. Both issues (installer and svn) have been solved. May someone with the appropiate rights please close this bug.

Thanks, Rossi

comment:11 by anevilyak, 11 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.