Opened 11 years ago

Closed 5 years ago

#2684 closed bug (invalid)

I can't connect SE K800i

Reported by: Hubert Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I can't connect cell phone Sony Ericson K800i by USB

screen: http://www.wrzuta.pl/obraz/7fKo0OKCJl/

Attachments (3)

DSC00250(2).JPG (66.8 KB ) - added by Hubert 11 years ago.
usb 2.0
DSC00251.JPG (48.4 KB ) - added by Hubert 11 years ago.
usb 1.1
DSC00365.JPG (245.0 KB ) - added by Hubert 11 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 by mmlr, 11 years ago

Sorry but that screenshot is completely unreadable. Can you please make a better one or transcribe the content here? You can omit the numbers and just write down the text. I take it it KDLed right after plugging the device in? What mode were you trying to use, phone or mass storage? Can you give some more details to the host machine where this is happening. I know that SE phones often come with USB 1.1 and not USB 2.0, still I wonder if this is really the case for a recent one like the K800i. If it comes with USB 2.0 UHCI should not be used at all.

comment:2 by Hubert, 11 years ago

Hi mmlr and sorry for bad photo I use mass storage options with cell phone, when use phone mode I have nothing special - Haiku work far but I don't see phone nowhere in the system.

I connect phone with GA-M61PME-S2 mainboard. I tried both from usb2 as well as I switched in bios on usb 1.1. But every time when I connect to usb cell phone and I choose mass storage KDL error follows: "ohci finish tread"

PS. Sorry for my english.

by Hubert, 11 years ago

Attachment: DSC00250(2).JPG added

usb 2.0

by Hubert, 11 years ago

Attachment: DSC00251.JPG added

usb 1.1

comment:3 by Hubert, 11 years ago

I solved partly this problem , fault be placed after side of error in nforce. See #3260 Cellphone nicely be seen by Haiku now but it can not be correctly mounted. Tested only USB2.0 for now.

comment:4 by mmlr, 11 years ago

Status: newassigned

Can you please check with a revision >= hrev28934.

comment:5 by Hubert, 11 years ago

I tested hrev28977. I connect SE and promptly have PANIC.

by Hubert, 11 years ago

Attachment: DSC00365.JPG added

comment:6 by Hubert, 11 years ago

So. I connect now SE W890i with M2 2GB card. Cellphone nicely be seen by Haiku too (see K800i). Memory in cell not correctly mounted but memory card mounted correctly and I can use this (data exchange).

comment:7 by scottmc, 8 years ago

Can you recheck this with a recent Haiku build? Do you even still have the same cell phone?

comment:8 by luroh, 5 years ago

Resolution: invalid
Status: in-progressclosed

Closing due to lack of feedback.

Note: See TracTickets for help on using tickets.