Opened 11 years ago

Closed 9 years ago

#2690 closed bug (fixed)

PANIC: ASSERT FAILED (headers/private/kernel/util/DoublyLinkedList.h:464): fFirst != __null && fLast != _ ... )

Reported by: emitrax Owned by: axeld
Priority: high Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Happene on shutdown after doing heavy I/O.

list: 0x90bf1d38, element: 0x807b92c0
PANIC: ASSERT FAILED (headers/private/kernel/util/DoublyLinkedList.h:464): fFirst != __null && fLast != __null && (fFirst != fLast ||
Welcome to Kernel Debugging Land...
Thread 6949 "shutdown worker" running on CPU 0
kdebug> bt
stack trace for thread 6949 "shutdown worker"
    kernel stack: 0x91ed1000 to 0x91ed5000
      user stack: 0x70145000 to 0x70185000
frame            caller     <image>:function + offset
 0 91ed4a34 (+  48) 800566a1   <kernel>:invoke_debugger_command + 0x00f5
 1 91ed4a64 (+  64) 80056491   <kernel>:invoke_pipe_segment__FP21debugger_command_pipelPc + 0x0079
 2 91ed4aa4 (+  64) 80056819   <kernel>:invoke_debugger_command_pipe + 0x009d
 3 91ed4ae4 (+  48) 80057d54   <kernel>:_ParseCommandPipe__16ExpressionParserRi + 0x0234
 4 91ed4b14 (+  64) 8005718e   <kernel>:EvaluateCommand__16ExpressionParserPCcRi + 0x02ba
 5 91ed4b54 (+ 224) 8005917c   <kernel>:evaluate_debug_command + 0x0088
 6 91ed4c34 (+  64) 80054aa2   <kernel>:kernel_debugger_loop__Fv + 0x01ae
 7 91ed4c74 (+  48) 80055675   <kernel>:kernel_debugger + 0x0121
 8 91ed4ca4 (+ 192) 80055549   <kernel>:panic + 0x0029
 9 91ed4d64 (+  96) 8002bbf3   <kernel>:write_cached_block__FP11block_cacheP12cached_blockb + 0x0133
10 91ed4dc4 (+  64) 8002e306   <kernel>:block_cache_sync + 0x006a
11 91ed4e04 (+  48) 80598dd3   <bfs>:_FlushLog__7JournalbT1 + 0x00e3
12 91ed4e34 (+  48) 80598e1f   <bfs>:FlushLogAndBlocks__7Journal + 0x002b
13 91ed4e64 (+  48) 8059cd8d   <bfs>:Sync__6Volume + 0x0025
14 91ed4e94 (+  48) 8059df36   <bfs>:bfs_sync__FP9fs_volume + 0x0022
15 91ed4ec4 (+  64) 80092ff4   <kernel>:fs_sync__Fl + 0x0144
16 91ed4f04 (+  48) 80093519   <kernel>:_kern_sync + 0x0019
17 91ed4f34 (+  16) 800946cb   <kernel>:_user_sync + 0x000b
18 91ed4f44 (+ 100) 800be6f2   <kernel>:pre_syscall_debug_done + 0x0002 (nearest)
user iframe at 0x91ed4fa8 (end = 0x91ed5000)
 eax 0x57           ebx 0x5b6d40        ecx 0x70184ef0   edx 0xffff0104
 esi 0x1802bfb0     edi 0x1802bdb8      ebp 0x70184f0c   esp 0x91ed4fdc
 eip 0xffff0104  eflags 0x212      user esp 0x70184ef0
 vector: 0x63, error code: 0x0
19 91ed4fa8 (+   0) ffff0104
20 70184f0c (+  64) 0024bdbf   <_APP_>:_WorkerDoShutdown__15ShutdownProcess + 0x01e7
21 70184f4c (+  48) 0024bb2c   <_APP_>:_Worker__15ShutdownProcess + 0x0020
22 70184f7c (+  48) 0024bb03   <_APP_>:_WorkerEntry__15ShutdownProcessPv + 0x001f
23 70184fac (+  48) 0052ebd8   <libroot.so>:_get_next_team_info + 0x005c (nearest)
24 70184fdc (+   0) 70184fec   258174:shutdown worker_6949_stack@0x70145000 + 0x3ffec
kdebug> reboot

Attachments (1)

100_2604.jpg (285.9 KB ) - added by apn4m3rdrock 10 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 by apn4m3rdrock, 10 years ago

Build: hrev32063-gcc4 ( Aug 1 2009)

Initial error message read : /home/haiku/Haiku/trunk/headers/private/kernel/util/DoublyLinkedList.h:467): fFrist!=NULL &&fLast !=NULL thread 340 MoveTask

Reproducing: Copying large file (ISO image approx 700Mb, kdumped in seconds) from one vfat partition to another vfat partition and the kernel dumped core. Both of them were mounted as in RW mode.

PS: Photo of KDMP Attached: 100_2604.jpg

by apn4m3rdrock, 10 years ago

Attachment: 100_2604.jpg added

in reply to:  1 comment:2 by Grey, 10 years ago

Replying to apn4m3rdrock:

Build: hrev32063-gcc4 ( Aug 1 2009)

Initial error message read : /home/haiku/Haiku/trunk/headers/private/kernel/util/DoublyLinkedList.h:467): fFrist!=NULL &&fLast !=NULL thread 340 MoveTask

Reproducing: Copying large file (ISO image approx 700Mb, kdumped in seconds) from one vfat partition to another vfat partition and the kernel dumped core. Both of them were mounted as in RW mode.

PS: Photo of KDMP Attached: 100_2604.jpg

The same bug for hrev35234-gcc4. Copying a lot of small files from vfat partition to bfs partition.

comment:3 by emitrax, 9 years ago

I guess this can be considered closed.

The Journal:::FlushLog doesn't use the block cache anymore, and the latter doesn't have a double linked list anyway.

Please confirm.

comment:4 by axeld, 9 years ago

Resolution: fixed
Status: newclosed
Version: R1/pre-alpha1R1/Development

The code hasn't changed in this regard (Journal::_FlushLog() still calls block_cache_sync() via Volume::FlushDevice(), and the cached_blocks are still maintained in doubly linked lists (not only, but that hasn't changed either).

Anyway, since the error hasn't been seen for so long anymore, I assume it has been fixed. Please reopen if not.

Note: See TracTickets for help on using tickets.