Opened 11 years ago

Closed 11 years ago

#2709 closed bug (fixed)

[bfs]: rm: FATAL: directory a/a/... changed dev/ino

Reported by: emitrax Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Creating directory doesn't seem to be a safe operation in Haiku. I actually managed to corrupt the file system by overwritting blocks already in use by system binaries, but since I can't seem to reproduce it consistently I'm not opening a bug about it yet.

Anyway, interrupting the following script, result in a error when trying to delete the directory just created.

for i in `seq 1 100`; do mkdir a; cd a; done

Screenshot attached.

Change History (10)

comment:1 Changed 11 years ago by bonefish

Revision?

PS: I can't see any attachment. Trac problem or forgot to add it?

comment:3 Changed 11 years ago by bonefish

Revision?

comment:4 Changed 11 years ago by emitrax

Latest at the time of the bug report. Can tell you the number later. Do you happen to have any idea?

comment:5 Changed 11 years ago by emitrax

Just happened again with hrev27386.

comment:6 Changed 11 years ago by digitalteufel

I see this bug when the build system (self-hosting) is trying to remove some files after unzipping each optional package.

eg:

Unzipping generated/downloads/pe-2.4.1-x86.zip rm: FATAL: directory `generated/tmp/unzip/config/man' changed /dev/ino rm: FATAL: directory `generated/tmp/unzip/config/man' changed /dev/ino

comment:7 Changed 11 years ago by axeld

I just tried with hrev27949 under VMware, but I cannot reproduce it, even with $(seq 1000). Is it still reproducible for both of you?

comment:8 Changed 11 years ago by anevilyak

I can reproduce this one 100% of the time, all I have to do is build Haiku in Haiku and specify adding all optional packages in UserBuildConfig. During the optional package install portion of the build, this bug is triggered.

comment:9 Changed 11 years ago by mmlr

This one is probably fixed in hrev28214, please verify. If this was indeed the problem, it would have happened only after running the script multiple times in the same session.

comment:10 Changed 11 years ago by axeld

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.