Opened 13 years ago

Closed 4 weeks ago

#2724 closed bug (fixed)

B_OUTLINE_RESIZE not implemented

Reported by: julun Owned by: nobody
Priority: normal Milestone: R1/beta3
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description


Attachments (1)

B_OUTLINE_RESIZE-1.patch (14.1 KB ) - added by TriEdgeAI 8 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 by anevilyak, 13 years ago

Component: - GeneralKits/Interface Kit

comment:2 by siarzhuk, 8 years ago

Owner: changed from axeld to siarzhuk
Status: newassigned

This ticket was published as GCI 2012 task. ​http://google-melange.appspot.com/gci/task/view/google/gci2012/7984202 So I take ownership of it.

by TriEdgeAI, 8 years ago

Attachment: B_OUTLINE_RESIZE-1.patch added

comment:3 by axeld, 8 years ago

Component: Kits/Interface KitServers/app_server
Version: R1/pre-alpha1R1/Development

Thanks, TriEdgeAl! The patch looks nicely, I could even only find two minor coding style violations. I haven't tested it, though (since siarzhuk wanted to look at it, too).

Have you by any chance written a test application for this? If so, src/tests/servers/app/ would be a natural place for it -- patch welcome!

in reply to:  3 comment:4 by siarzhuk, 8 years ago

Replying to axeld:

Have you by any chance written a test application for this? If so, src/tests/servers/app/ would be a natural place for it -- patch welcome!

As far as I remember, our Magnify application is the one, using B_OUTLINE_RESIZE flag. I have just tested this patch with one of my applications before noticed about Magnify. But the special test application is welcome too! This patch utilizes "non-canonical" way of outline resize - it draws natural window border "teared" off the window. In my personal taste it looks a bit like a buggy behavior so I would like to see some polishing of it. But this is my personal meaning. Another issue - drawing of border on minimizing the frame is hidden under the views of this window - that is loking not nice IMO. As far as I know TriEdge AI wanted to continue working on this feature "in calm" after finishing GCI competition so we can hear from him some more news in the future. :-)

comment:5 by axeld, 8 years ago

Thanks siarzhuk! I agree that tearing off the border isn't a nice visual effect; I didn't even get the idea that the patch would do that :-)

Still, I think it's the right way to let the decorator handle this case.

comment:6 by mmadia, 8 years ago

patch: 01

comment:7 by mmadia, 8 years ago

Is it worthwhile to apply this patch as-is and open new tickets for the tearing issues?

in reply to:  7 comment:8 by siarzhuk, 8 years ago

Replying to mmadia:

Is it worthwhile to apply this patch as-is and open new tickets for the tearing issues?

Tearing off is not a problem - the problem is that we have no right solution at all. ;-)

comment:9 by siarzhuk, 6 years ago

Owner: changed from siarzhuk to nobody

Those were taken some years ago as potential GCI tasks. Unfortunately no place is available for them in my schedule at this days.

comment:10 by pulkomandy, 3 years ago

comment:11 by pulkomandy, 3 years ago

patch: 10

comment:12 by axeld, 7 months ago

Milestone: R1R1.1

comment:13 by bitigchi, 4 weeks ago

Implemented in hrev55002.

comment:14 by nephele, 4 weeks ago

Milestone: R1.1R1/beta3
Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.