Opened 11 years ago

Closed 10 years ago

#2729 closed bug (fixed)

Changing a filetype won't change icon live

Reported by: humdinger Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

On vmware, hrev27407.

If you change the type of a file with the FileType Add-On the changed icon is only updated after you close and re-open the folder.

Change History (7)

comment:1 Changed 11 years ago by axeld

Can you explain the problem a bit more detailed? At least I cannot reproduce it at all: I have a text file in an open (in Tracker) folder, or on the Desktop.

When I change the MIME type of that file using the FileType add-on, the icon in Tracker is changed immediately.

comment:2 Changed 11 years ago by humdinger

Hmmm... there are no more details. :) I do it exactly like you, but the icon and the Kind attribute are changed only after re-opening the folder. The type, however, really did change, as a catattr BEOS:TYPE or invoking the FileType Add-On or "Get info..." proves.

I can totally reproduce this.

comment:3 Changed 11 years ago by axeld

Do you build your own images? Are you using GCC4 to build them?

comment:4 Changed 11 years ago by humdinger

Nope. I get the vmimages straight from Haiku Files. Maybe I should get a never revision and test again?

comment:5 Changed 10 years ago by korli

Can't reproduce this as well.

comment:6 Changed 10 years ago by humdinger

I can't either. :) Using hrev29002 everything's working fine. Please close the ticked. Thanks whoever committed whatever fixed this bug.

comment:7 Changed 10 years ago by korli

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.