Opened 11 years ago

Closed 10 years ago

#2736 closed bug (invalid)

BePDF no longer renders files

Reported by: kvdman Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

BePDF no longer renders files. Could this have to do with the removal of the BitStream font? I'm pretty sure BePDF still worked at hrev27353.

Attachments (1)

1.jpg (151.1 KB) - added by kvdman 11 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by mmlr

Can you please check if hrev27587 makes any difference? What document did you try to open? I have some documents that use common windows fonts and don't include them in the document and don't specify a substitution font. In that case BePDF cannot render them. You should get those warnings in the warnings dialog though.

comment:2 Changed 11 years ago by kvdman

I'll include more info shortly and try 27587.

Also, if Bitstream was removed and it's pretty popular, shouldn't it be symlinked to another popular font?

comment:3 Changed 11 years ago by kvdman

hrev27587 makes no difference. As I said, the files I'm testing worked previously with BePDF and Haiku,

They are:

Practical File System Design Programming the Be Operating System (available on Senryu).

The output mostly spat out code lines. I did manage a screen shot where a different message popped up.

See attached please.

Changed 11 years ago by kvdman

Attachment: 1.jpg added

comment:4 Changed 11 years ago by axeld

I haven't tried to reproduce it before, but I cannot reproduce this with hrev27621 with the aforementioned document. Can you please retry if it works for you now?

If it still doesn't I must assume there is something wrong at your end.

comment:5 Changed 11 years ago by kvdman

Hi Axel,

I was using v0.9.4 of BePDF. I tried hrev27624 and it still didn't render the files (where it did previously)...

I just tried the latest version that you included as an optional package, and it works fine.

comment:6 Changed 10 years ago by jackburton

So, should we close this bug ?

comment:7 Changed 10 years ago by axeld

Resolution: invalid
Status: newclosed

Yes. I guess the older BePDF version did used hard-coded fallback fonts.

Note: See TracTickets for help on using tickets.