Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#276 closed bug (fixed)

[FileTypes] crash in menu

Reported by: diver Owned by: jackburton
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

FileTypes crash in certaint situation when clicking menu. Steps to reproduce: start /system/Tracker open /boot/beos/preferences start FileTypes move FileTypes window in the right left corner activate preferences window press Alt+a to select all items and press enter wait until all apps to load and close them now press any FileTypes menu to crash it

*Note that you can't type anything in debugger until you switch to another window and back to debugger

Tested with rev16685 under vmware. screenshot will follow.

Attachments (1)

FyleTypes.PNG (27.2 KB) - added by diver 13 years ago.
back trace

Download all attachments as: .zip

Change History (8)

Changed 13 years ago by diver

Attachment: FyleTypes.PNG added

back trace

comment:1 Changed 13 years ago by jackburton

Owner: changed from bpmagic@… to jackburton

comment:2 Changed 13 years ago by jackburton

Can you check if this still happens after hrev16867 ?

comment:3 Changed 13 years ago by diver

(In reply to comment #2)

Can you check if this still happens after hrev16867 ?

Just dloaded hrev16868 and it happens here too. BTW, i think there is another bug in listview as all/several items disappear before FileTypes crash.

comment:4 Changed 13 years ago by jackburton

Yes, I could reproduce it. Could be a bug in BOutlineListView or anything, maybe related to low memory situations (when I launched all preference apps, some didn't show up, probably because there wasn't enough free memory)

comment:5 Changed 13 years ago by jackburton

Still valid ? I cannot reproduce it anymore

comment:6 Changed 13 years ago by diver

I think it's fixed, closing bug.

comment:7 Changed 13 years ago by diver

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.