Opened 11 years ago

Closed 11 years ago

#2783 closed bug (fixed)

boot slow because of disks

Reported by: Adek336 Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have three PATA hard drives, a CD drive and one SATA hard drive. For some revisions now, Haiku boots much longer. It takes like, 85 seconds to boot (from the GRUB menu to the showing of the desktop), 65 of which is spent on the disk icon.

Expected behaviour: it takes less time to boot.

Change History (4)

comment:1 by axeld, 11 years ago

Have you switched to the "ata" bus manager? Because that one is known to take much longer to boot for now.

in reply to:  1 comment:2 by Adek336, 11 years ago

Replying to axeld:

Have you switched to the "ata" bus manager? Because that one is known to take much longer to boot for now.

I'm not sure, I haven't done any explicit actions to choose one of these, but in the log I get a lot of "IDE: something something" and "ide: something something" messages.

I now have found out that I have installed a hard drive, that when it is not physically attached, Haiku doesn't take excessive amounts of time to boot. However when it is attached I get something like

KERN: intel: pm_identify_partition (...)
KERN: check_sense: Hardware error
...

lots of times. FreeBSD also complains about this drive and boots a bit faster (probably performs less tries), Windows is installed on this very drive, and, Windows boots very fast and works well.

So I believe this is a problem with my drive, but not with it being physically broken but perhaps the partition table is a bit flawed.

I will try to find out what is wrong with the drive. Please leave this bug open until I ensure that the problem is in fact caused by something like a broken partition table and not with Haiku (and FreeBSD) erroneously failing to read a good partition table.

Also, regardless of if the mentioned drive is attached, I get large quantities of

KERN: ide: reset_device() 0x91587e80 failed, calling reset_bus

is this a sign of a problem or is it normal that it has problems with resetting a bus every single boot?

comment:3 by Adek336, 11 years ago

works well in 27994, boot time is 25 seconds, of which 8 seconds go for the disk-icon-stage for the four drives.

comment:4 by mmlr, 11 years ago

Resolution: fixed
Status: newclosed

That was a symptom of hrev27994 as well. On boot the disk device manager scans the available partitions and would cause errors/resets when reaching ones below the 128GB barrier.

Note: See TracTickets for help on using tickets.